Surface 2 is not able to connect to wifi at home, yet connects to personal hotspot on phone?

Discussion in 'Microsoft Surface 2' started by Chilivic49, Jun 1, 2016.

  1. Chilivic49

    Chilivic49 New Member

    Joined:
    Jun 1, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    S2
    I have not been able to connect to my home wifi SSID, either normal or 5G, I get an unable to connect to this network, yet I am able to connect to a personal hotspot on my phone. My phone, & other laptop connects to the home wifi no problem. Do you have any suggestions on why it won't connect? The password is entered & it still does not connect.
     
  2. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Welcome to the forum

    Are you getting an error? Is it saying saved? Have you restarted the router?

    Has it ever worked?
     
  3. Chilivic49

    Chilivic49 New Member

    Joined:
    Jun 1, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    S2
    Leeshor: I have been on with my internet provider, we reset the Wifi password, I can connect to my personal hotspot on my phone, but not the SSID that I was connected to for the last two years. It stopped working & gives me the error: Can't connect to this network. Microsoft Surface 2 is the machine, Windows 8.1, any guidance is appreciated!
     
  4. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Your next step would be to try a public hotspot or a friend's router/WiFi. I suspect an issue with your router but you need to be certain your WiFi works somewhere other than your phone. If it does you need to escalate the issue with your service provider.
     
  5. Chilivic49

    Chilivic49 New Member

    Joined:
    Jun 1, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    S2
    I was able to connect to a WIFI outside Home SSID. Any ideas on what would not allow me to connect to a WIFI on my Surface 2 that is 2-3 years old?
     
  6. Chilivic49

    Chilivic49 New Member

    Joined:
    Jun 1, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    S2
    I will escalate with my service provider, for the surface wouldn't have a corrupt or smart enough to quarantine.
     
  7. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Since this started have you restarted the router? If not, power it down for a full minute then wait 5 minutes after powering up before trying to use it again.
     
  8. toaf

    toaf Member

    Joined:
    Jul 9, 2014
    Messages:
    196
    Likes Received:
    19
    Trophy Points:
    18
    Location:
    infront of my surface you silly person
    My Device:
    SPro2
    if memory serves, think there was some windows wifi setting deep in the depths of settings. but if it works at random places, maybe a setting in the router. its been so long.

    but it is a log into the router issue?
     
  9. garryknight

    garryknight New Member

    Joined:
    May 18, 2016
    Messages:
    24
    Likes Received:
    3
    Trophy Points:
    3
    My Device:
    SPro3
    I have the same problem with every new device I bring home. In my router's settings, I have MAC filtering set up to 'Deny all devices unless in the Wireless Filter List'. So I have to find out the device's WIFI MAC address and enter it into the list, then reset the router. Occasionally I also have to reboot the new device before it will 'see' that the connection has changed.

    If this isn't the solution to your problem, I hope it helps someone else down the line.
     
    sharpuser likes this.

Share This Page