Surface Book 2 GPU overheating while in sleep or screen off

Discussion in 'Microsoft Surface Help' started by Netsrv, Apr 28, 2018.

  1. Netsrv

    Netsrv New Member

    Joined:
    Apr 28, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface Book
    Hello, I recently purchased a Surface Book 2 i7 256 GB 13.5 inch with the Nvidia 1050 GTX. I was very excited with this device until I noticed the first problems. The screen is a little bit bent at the right top corner and as known this devices suffers from the coil whine issue, but it worked great. I tweaked some settings with Throttlestop to get rid of the coil whine and now it's almost completely gone (and losing just a little bit performance). A few days ago I noticed that when I left a program running on the dedicated GPU with the setting changed to high performance in the Nvidia control center, the fans stopped spinning while sleeping but on resuming the system they started spinning on max. I checked the temperature of the GPU and it reached as high as 87° C. This doesn't seem normal to me. I did some more tests and always got the same result. It seems that when sleeping or when the screen is turned off without sleeping (by disabling the connected standby in the registry), the GPU keeps on running with a high clock speed even when there isn't any demand by the application. This only happens when the settings is set on high performance in the Nvidia control center, otherwise it will lower its clock speed. Normally this shouldn't be a big concern, but it really gets a problem when the surface book decides to turn off the fans of the GPU. The temperature rises until it reaches the limit and then starts throttling and keeps on doing this until the surface book is resumed from the sleep or screen off state. Does anyone have the same problem? Is this a setting in the BIOS or is it adjustable in the registry? At this moment I disabled sleep and screen off completely, because I don't want to ruin my GPU.
     
  2. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,847
    Likes Received:
    1,863
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    This machines are not designed to be tweaked...I wouldn't recommend using tools like Throttlestop and S0iX should be re-enabled as the system from the UEFI to Windows 10 is tuned for it...
     
  3. Netsrv

    Netsrv New Member

    Joined:
    Apr 28, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface Book
    I understand that tweaking may cause my problem, but when Microsoft doesn't address the coil whine issue there isn't much left but trying to solve it yourself. I hope they provide a solution for that problem soon so I can remove my tweaks. So you suggest that the S0ix states would solve my problem by putting the GPU in a sleep state as well? Because even when they are activated I got the same problem with my GPU. My desktop programs stop running on the background (I checked this by letting some music play and it stops playing when the screen is off), but when I resume the surface from sleep my GPU fan goes spinning like crazy and the surface is really hot to the touch. I can't measure the temperature because my measuring program halts by the S0ix state but it does seem like the same problem when the S0ix states are disabled. Any suggestions?
     
  4. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,847
    Likes Received:
    1,863
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    I would say its the Throttlestop or possibly you have a defective machine.
     

Share This Page