Surface Pro 2 Auto Sleep not working

Discussion in 'Microsoft Surface Pro 2' started by felixwon9, Jan 28, 2014.

  1. felixwon9

    felixwon9 New Member

    Joined:
    Nov 25, 2013
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    0
    So after the December Firmware updates, my Surface was one of many which suffered from the 1 hour wakeup.

    Now I was patient with Microsoft and the issue is now fixed since the January 18 update. Another issue though, which used to work properly has arised.

    The computer just won't go to sleep. I've tried various things by playing around with powercfg and also the advanced settings in Power Options. Nothing seems to budge. I've tried resetting everything to default and disable USB suspend and restarting and all that but nothing seems to budge.

    I know some of you have had this problem even before December and I was wondering if it's just me or if anyway can give their SP2 a quick test run to see if auto-sleep is working for you? There's only one thread on the official Microsoft forums and it doesn't seem like it's picking up like the auto-wake issue which affected almost literally...everybody.

    I really would not want to reset the system because it'll take some work to even reinstall all the apps and what not so if anyone could help me out, it'd be great appreciated!
     
  2. bryanbreguet

    bryanbreguet New Member

    Joined:
    Jan 28, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I had the exact same issue (auto wake-up fixed by the January firmware but auto-sleep still not working).

    For me (and a lot of Windows 8 users), the issue was HomeGroup. So try this: turn off wifi and see if the surface goes to sleep (just put the timer at like 1 minute). If yes, then turn on wifi but turn off the HomeGroup. For me, it worked.

    I'm guessing there would be a way to keep HomeGroup but still has the auto-sleep feature working, but since I use third party programs for my streaming needs (ps3 media server for instance), turning off HomeGroup was easier for me. If you look online, you'll see lot of Windows 8 users with this issue.

    Hope it helped!
     
    Last edited: Jan 28, 2014
  3. Rvacha

    Rvacha Member

    Joined:
    Mar 9, 2013
    Messages:
    181
    Likes Received:
    14
    Trophy Points:
    18
    I have this problem now and I do not have homegroup enabled. Ugh. This mess is getting tiring.
     
  4. Rvacha

    Rvacha Member

    Joined:
    Mar 9, 2013
    Messages:
    181
    Likes Received:
    14
    Trophy Points:
    18
    But... turning off WiFi does work. Hum...
     
  5. Dayton

    Dayton Member

    Joined:
    Dec 19, 2013
    Messages:
    75
    Likes Received:
    2
    Trophy Points:
    8
    This can happen when you are hosting a shared network resource or when attached to a network resource, but the latter is less likely. Turning off WiFi would eliminate what I just mentioned.
     
  6. felixwon9

    felixwon9 New Member

    Joined:
    Nov 25, 2013
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    0
    Sorry for the really late reply guys but yes, disabling homegroup indeed fixed all the problems. I wasn't aware that it was a Windows 8 problem so never bothered to google with regards to Windows but only with keywords like "Surface" and "Sleep" not working. I couldn't believe it when I made it sleep since it just seemed so out of place but hey, now my SP2 is back! I've been using it more than ever before the botched Dec. 15 update and it's been serving me very, very well =D Again, thanks guys and I hope more people can take a look at this if they're experiencing the same problem. Cheers =)
     
    1 person likes this.

Share This Page

Search tags for this page

autosleep surface pro 2

,
surface 2 pro no sleeping 10
,
surface does not sleep
,
surface pro 2 autosleep
,
surface pro 2 does not sleep
,

surface pro 2 sleep not working

,
surface pro 3 sleep not working
,
surface pro will not auto sleep
,
surface pro will not sleep
,
surface pro wont suspend