Surface Pro 3 Wi-Fi issues (slow connection)

Discussion in 'Microsoft Surface Help' started by phlo, Feb 23, 2015.

  1. phlo

    phlo New Member

    Joined:
    Jan 25, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I recently bought a Surface Pro 3 and booted it up. I installed all updates via windows update. But since day 1 I'm encountering slow Wi-Fi-connection.

    Via ethernet-adapter I get max. 30Mbit/s. But via Wi-Fi only the following values:
    (I tested with two different routers)
    1. Linksys via 5GHz: max. 5Mbit/s
    2. Fritz!Box via 5GHz: max. 11Mbit/s
    I also own a Lenovo ThinkPad and I get the full 30Mbit/s over Wi-Fi (both routers), so this seems to be a Surface-related issue. I also formatted and installed a fresh Win 8.1 Pro copy, but I'm still encountering the exact same values.

    Is this a hardware-defect and I need to send my surface in or is there a possible fix?

    Greetings
    phlo
     
  2. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,096
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Can you give us more information on the Linksys such as model number and firmware version? Also, I've seen others having issues using 802.11AC WLAN on the FritzBox, these routers don't seem to function with the newer cards.

    You could go into the advanced settings and set the SP3 to use Wireless "N" under the advanced tab on the Device Properties.
     
  3. phlo

    phlo New Member

    Joined:
    Jan 25, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for your quick answer.

    Linksys E4200: DD-WRT v24-sp2 (03/25/13) big (SVN revision 21061)
    FRITZ!Box Fon WLAN 7270 v3: FRITZ!OS 06.05

    The Linksys doesn't support 802.11AC and is set to N-Only (5GHz) and the FritzBox doesn't support it neither and is set to 802.11n+a.

    How am I supposed to switch the Wireless-card to "N-only"? In the advanced tab (Device Manager -> Marvell AVASTAR Wireless-AC -> Advanced) I can only choose between "Band: 2.4GHz only / 5GHz only / Auto", "Packet Coalescing: "Disabled / Enabled" and "Wake on pattern match: Disabled / Enabled".

    Greetings
    phlo
     
    Last edited: Feb 23, 2015
  4. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,096
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Ah....you are using DD-WRT, also known to have issues with the Marvell WLAN Adapter. You are correct about the Advanced Tab as it looks like it was removed again. You can still do it via a reg hack but not recommended.

    I would look for an updated DD-WRT Firmware/update or perhaps consider updating your router. I get 866 Mbps on mine on 5GHz...
     
  5. phlo

    phlo New Member

    Joined:
    Jan 25, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Wowzers, 866 Mbps is pretty nice!

    Hm, DD-WRT is already the latest version, this also applies for the FritzBox. Is this a general problem with the WLAN-Adapter or is there a chance of getting rid of it by sending in the surface?
     
  6. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,096
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Many older routers are struggling with the newer WLAN Adapters from all of the major players (Broadcom, Intel and Marvell), it has to do with how negotiations are handled between the router and WLAN, add to that the newer network stack in Windows 8.1 and later you end up with incompatibilities. I had an older D-Link Router (N750) it I was only getting 5 Mbps with my Surface Pro 2 on Wireless N, so I upgraded to a Netgear R7000 Nighthawk AC Router, I saw immediate improvements with the SP2, now I was getting 144-200 Mbps, when I updated all of my SP2s to SP3s we are now seeing just under gigabit speed...
     
    phlo likes this.
  7. phlo

    phlo New Member

    Joined:
    Jan 25, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    That is too bad I have to upgrade, but otherwise great to hear, that my Surface doesn't have a major hardware-issue.
    Thank you for your advices, my next investment will be a new router, I guess. ;)

    Thanks a lot
    phlo
     
  8. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,334
    Likes Received:
    1,279
    Trophy Points:
    113
    I only have a measly 2.4 ghz Wireless N Router that supports a max 160 mbps connection and I typically get 130. not that it matters as my Inet link is 50mbps so I don't see any need to change my router.

    Id definitely try a different router first unless you have it in the basement and you're connecting from the second floor. Those speeds are definitely a problem.

    One day I connected a USB hub and 2 wireless USB adapters then bridged the connections for 390 mbps :) Still, 50mbps from the Inet.
     

Share This Page

Search tags for this page
marvell avastar wake on pattern match
,

packet coalescing surface pro 3

,
surface pro 3 internet slow
,

surface pro 3 slow internet

,
surface pro 3 slow internet connection
,
surface pro 3 slow wifi
,

surface pro 3 wifi issues 2015

,

surface pro 3 wifi slow

,
surface pro 3 wireless slow
,
wifi slow surface pro 3 2015