Surface pro screen brighness jumping around

Discussion in 'Microsoft Surface Pro' started by Adamrb25, Feb 13, 2013.

  1. Adamrb25

    Adamrb25 New Member

    Joined:
    Feb 13, 2013
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    I've noticed my screen brightness changes with videos mostly. I've turned off all the settings that control brighness but its still there just not as bad. It seems like somthing to do with helping the screen get better contrast but its still annoying. Have you guys noticed this as well? I posted earlier about my surface going to mute on its own with the touch cover in another thred as well.But besides these two minor glitches I really like my surface, I love saying to my wife can your ipad do this....and it happens quite often.
     
  2. souldier

    souldier Active Member

    Joined:
    Feb 5, 2013
    Messages:
    243
    Likes Received:
    27
    Trophy Points:
    28
    not sure what you can do. Did you turn off automatic screen brightness adjustment in pc settings? go to pc settings then go to the general section and you'll find it there
     
  3. Mr.NK

    Mr.NK Super Moderator Staff Member

    Joined:
    Oct 22, 2012
    Messages:
    402
    Likes Received:
    46
    Trophy Points:
    0
    Location:
    Berlin
    My Device:
    RT
    Even iif you turn of the brightness adjustment, there'll alwys be an amount of adjustment by the screen to get you nice black levels/contrasts (as for watching movies).
     
  4. marcux

    marcux Member

    Joined:
    Feb 7, 2013
    Messages:
    40
    Likes Received:
    9
    Trophy Points:
    8
    I believe this is the automatic charging that is doing this, it will top off the battery to 100% and stop so it does not overcharge the battery. Then when the battery is at 99% is will begin charging again, that is what I noticed. during that time it will dim. test to see if it's only doing it at 100% battery with the power connecter attached.

    It will keep brightning and dimming over and over again, seems like another fix might be needed.
     
  5. J515OP

    J515OP Super Moderator

    Joined:
    Jun 19, 2012
    Messages:
    2,177
    Likes Received:
    262
    Trophy Points:
    0
    Location:
    Northern CA
    My Device:
    RT
    Just go into power settings and make the brightness the same for on battery and on charger. This is a standard feature of Windows to save battery by lowering brightness when on battery.

    Desktop>Control>Panel>Power Options>Edit Plan Settings> adjust on battery brightness and plugged in brightness to the same level.

    Also make sure the auto brightness is off as mentioned previously.
     
  6. vook

    vook Member

    Joined:
    Feb 12, 2013
    Messages:
    37
    Likes Received:
    4
    Trophy Points:
    8
    Mine does that if the power cable is not firmly attached
     
  7. Soylent

    Soylent New Member

    Joined:
    Feb 26, 2013
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Florida, USA
  8. souldier

    souldier Active Member

    Joined:
    Feb 5, 2013
    Messages:
    243
    Likes Received:
    27
    Trophy Points:
    28
    Try charging with different outlets and see what happens. Yesterday I was plugged into a faulty outlet, and the screen brightness was jumping all over the place. I switched out lets and now its perfectly fine.

    Secondly, often I keep my surface plugged in even at 100%. I don't experience any jump in brightness whatsoever. To my understanding, when the pro is fully charged, the battery will be bypassed and will run directly on AC power. BatteryCare - Proper laptop battery usage guide
     
  9. bosamar

    bosamar Well-Known Member

    Joined:
    Nov 10, 2012
    Messages:
    1,453
    Likes Received:
    78
    Trophy Points:
    48
    My Device:
    RT
  10. Gah

    Gah New Member

    Joined:
    Mar 4, 2013
    Messages:
    4
    Likes Received:
    3
    Trophy Points:
    0
    So this is not a bug, it's Intel's Display Power Saving Technology that dims the display based on brightness of dispalyed content. This feature is enabled by default when the laptop is on battery.

    To disable it you need to install Intel's graphics media control panel and go to Power tab, select "on battery" and untick "Display Power Saving Technology".

    I joined the forum just to say this, as I keep seeing news and threads saying it's a bug/problem.
     
    1 person likes this.
  11. YKinase

    YKinase New Member

    Joined:
    Mar 5, 2013
    Messages:
    20
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Boston, USA
    I installed the latest HD4000 INTEL drivers yesterday - I was wondering what that setting was for. Do you happen to know if the Power Plan profiles override that setting? On Battery, where this is an option on the Intel Display Options control panel, I don't notice a difference whether it is clicked or not.
     
  12. STLPilot

    STLPilot New Member

    Joined:
    Feb 27, 2013
    Messages:
    28
    Likes Received:
    2
    Trophy Points:
    3
    i turned off auto brightness and hasnt happened since ... someone let me know when they fix it :)
     

Share This Page

Search tags for this page
surface pro
,
surface pro 2 dimming problem
,

surface pro 2 screen keeps dimming

,
surface pro dims out and in troubleshoot
,
surface pro display dimming problem
,
surface pro screen dimming
,
surface pro screen dimming on its own
,
surface pro screen dims
,
surface pro screen keeps dimming
,
surface rt keeps dimming