Solved Surface Pro Type Cover wrong keymap

Discussion in 'Microsoft Surface Pro 3' started by followthesapper, Apr 18, 2016.

  1. followthesapper

    followthesapper Member

    Joined:
    Jun 26, 2012
    Messages:
    46
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Scotland
    I recently purchased a used SP3. It was obviously originally purchased in Netherlands, as when I set it up, I was given a choice of English or Dutch. My problem is that even though I have set everything up to use English (locale, keyboard etc), the mapping is incorrect on the type cover and it seems to be using the Dutch keyboard layout. Do I need to flash a UK factory image or something? I have been through EVERY setting I can find and selected UK, also cleaned the type cover connections but to no avail, please help.
     
  2. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    2,851
    Likes Received:
    1,030
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    Try pressing CTRL+SHIFT and see if you can toggle Dutch to English. Languages which have been set up are ADDED to the list, not generally replaced.

    Nu komt de aap uit de mouw.
     
  3. followthesapper

    followthesapper Member

    Joined:
    Jun 26, 2012
    Messages:
    46
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Scotland
    No didn't make any difference. Tried this script as well, still no difference.

    Get-WinUserLanguageList

    # lists the languges available to the logged on user

    $1 = New-WinUserLanguageList en-GB

    # create a new language list object that contains the language of your choice - e.g. es-ES for Spanish in Spain

    Set-WinUserLanguageList $1

    # replace the current language list with the one you've just created

    Get-WinUserLanguageList

    # lists the languges available to the logged on user - should show only the language you've set

    Logoff, reboot...

    I really am stumped.
     
  4. Plantje

    Plantje Member

    Joined:
    Jan 9, 2016
    Messages:
    310
    Likes Received:
    19
    Trophy Points:
    18
    Location:
    Zwolle, The Netherlands
    My Device:
    Surface 3 (Atom)
    I am Dutch so I'll have to translate stuff.

    These settings should be in: control panel --> clock, language and region --> language --> change input method
    Click the options and you will get to a screen where you can select "US international " as keyboard layout
     
    followthesapper likes this.
  5. followthesapper

    followthesapper Member

    Joined:
    Jun 26, 2012
    Messages:
    46
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Scotland
    SOLVED the problem, thank you!
     
  6. Plantje

    Plantje Member

    Joined:
    Jan 9, 2016
    Messages:
    310
    Likes Received:
    19
    Trophy Points:
    18
    Location:
    Zwolle, The Netherlands
    My Device:
    Surface 3 (Atom)
    These are the type of settings that are set during the initial setup. As you mentioned you did that right...

    Anyway...as well these are the type of settings that are not yet to be found in the Windows 10 settings. You'll have to go to the old fashioned "Control panel". I did manage to get there from the Windows 10 settings. Somewhere in the language settings I found a "more settings for language" link pointing to the location I mentioned above. But to be honest: they should add it to the normal settings if they want to ditch the control panel all together.

    Good to know that I was able to help!
     
    followthesapper likes this.

Share This Page