Surface Pro X screen brightness issue

Discussion in 'Surface Pro X' started by Geoff Arnold, Dec 2, 2019.

  1. Geoff Arnold

    Geoff Arnold New Member

    Joined:
    Nov 25, 2019
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    SurfaceProX
    I'm having an odd experience with the screen brightness of my SPX. Here's the sequence:

    1. Turn on the SPX to wake it from sleep. The screen appears to be at about 60% brightness.

    2. Press F7 (increase brightness). The screen brightness widget appears briefly, showing 100% brightness. The screen brightness doesn't change.

    3. Open Settings, navigate to System ->Display page. The Display brightness slider is at 100%. (Change brightness automatically is unchecked.)

    4. Click the Display brightness slider at about the 80% mark. The screen immediately brightens (confirming that it was well below 100%).

    5. Click the slider at the 100% mark. The screen brightens to 100%.
    This sequence is the only way I can get 100% brightness after the SPX has been in sleep mode. Thoughts?

    [Note: this is with the SPX connected to power. I haven't tried it on battery. The advanced power settings are standard Balanced. I've also posted this to the reddit SPX.]
     
  2. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,909
    Likes Received:
    1,385
    Trophy Points:
    113
    There seem to be a number of oddities with brightness on the Pro X, all we can hope for is an update from Microsoft to fix it. I just had to reboot to change brightness after the X hibernated and I was unable to change brightness at all. I guess the engineer working on this wasn't the brightest ... o_O
     
  3. WAR

    WAR Member

    Joined:
    May 13, 2014
    Messages:
    66
    Likes Received:
    6
    Trophy Points:
    8
    I've noticed my brightness varies while I'm using my device. I figured it will get fixed in an update.
     
  4. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,968
    Likes Received:
    1,885
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    SurfaceProX
    It appears to be fixed in the latest Insider Build for H12020...
     
  5. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,909
    Likes Received:
    1,385
    Trophy Points:
    113
    That's a bit surprising because these issues usually stem from firmware and driver problems.

    I won't likely be installing that any time soon, I haven't even installed 1909 yet :)
     
  6. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,968
    Likes Received:
    1,885
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    SurfaceProX
    I've been running the latest build and it is working as expected and the GSOD video driver issue is also gone...
     

Share This Page