Surface RT is being problematic

Discussion in 'Microsoft Surface Help' started by Brian DaSilva, Jul 3, 2014.

  1. Brian DaSilva

    Brian DaSilva New Member

    Joined:
    Jul 3, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hello, my Surface RT has been problematic for a while.

    Here are the issues:
    When I try to shutdown or restart the surface, it takes forever. <---Forced it to shut down, 8/15/2014
    Sometimes, turning on the Surface makes it show the surface logo for a sec and then it shuts down. It attempts to open recovery options sometimes, but fails as the surface shuts down. It successfully turns on after many attempts. <---This issue is occuring right now. (Confirmed 8/15/2014 to be having this issue)
    Trouble downloading apps from the windows store, apps just don't download.
    Will no longer connect to the internet <---Happened a couple of months ago or so, this issue was only temporary.
    Surface doesn't automatically update. <---Occuring right now.

    Can anyone help me out? I got the surface back in Christmas 2012, so it is out of warranty.
     
    Last edited: Aug 15, 2014
  2. Brian DaSilva

    Brian DaSilva New Member

    Joined:
    Jul 3, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Good news! I got the Surface to successfully turn on and it is connecting to the internet!
    EDIT: It also downloads apps from the windows store. Great!
     
  3. kundas1

    kundas1 Super Moderator Staff Member

    Joined:
    Dec 4, 2013
    Messages:
    1,653
    Likes Received:
    299
    Trophy Points:
    83
    My Device:
    SPro3
    is your surface RT a gen 1 or 2? also it sounds like you're having trouble with the SSD drive did you buy this second hand? how is it functioning when in use? is it slow / fast? I know when I had my RT 1 it was fast and quick but had trouble connecting to 2.4 GHz band but the 5 GHz was fast... is it under warranty still from MS if you need to send it in due to faulty SSD?
     
  4. Brian DaSilva

    Brian DaSilva New Member

    Joined:
    Jul 3, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Oh, great. It's dead, Jim!
    It was bricked. It's a gen 1.
    I was trying to reset it (deleting all personal files) and I already backed up. It was stuck restarting (didn't restart), so I shut off. I tried to turn it back on but with no avail. RIP. BTW it's out of warranty. The surface was fast when it worked.
     
  5. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,340
    Likes Received:
    1,279
    Trophy Points:
    113
    Calling Spock for a mind meld... or to check the event log...

    Ah well... never mind. :-(
     
  6. Brian DaSilva

    Brian DaSilva New Member

    Joined:
    Jul 3, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Alright, it's giving a sign of life. It has the issue stated in the OP (Surface logo shows for 1 second or less but shuts off) and it might take a while to get it up and running.
     
  7. evoqONE

    evoqONE New Member

    Joined:
    Sep 3, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1

    This same issue started with my Surface RT where it power up long enough to show the logo then shows battery status at 1 bar and then goes dark. The charging indicator doesn't light up as well.
    Were you able to go fix this issue??

    Thanks
     

Share This Page

Search tags for this page
surface rt taking forever to shut down
,

surface takes forever to restart

,
windows surface rt shuts down and restarts