System.exe High CPU Usage

Discussion in 'Microsoft Surface Pro 3' started by Philtastic, Nov 20, 2014.

  1. Philtastic

    Philtastic Active Member

    Joined:
    Jan 4, 2014
    Messages:
    381
    Likes Received:
    75
    Trophy Points:
    28
    Location:
    Canada
    My Device:
    SPro4
    I don't have a Surface Pro 3 but I wanted to know whether you guys have the same problem that was pretty common and still exists on the SP2. I was particularly reminded of that issue when I had it happen about 3 times today. Basically, at seemingly random times, System.exe will use 27-30% of the CPU for roughly an hour before it eventually stops. This will occur even and most annoying while on battery, cutting into battery life substantially. Putting the SP2 to sleep doesn't fix this as the process continues on wake. The only fix that I've seen is to restart the device which stops the high CPU usage. Often I'll notice this because my unit gets pretty warm even though I might be just surfing the web or reading a book.

    This has been around since roughly March of this year. I should note that this is a distinct issue from the SD card/USB high CPU usage case that was eventually fixed.

    If no one seems to have this problem, I might try doing a system refresh and see if that resolves things.
     
  2. nipponham

    nipponham Active Member

    Joined:
    Sep 24, 2014
    Messages:
    399
    Likes Received:
    78
    Trophy Points:
    28
    Location:
    Japan
    My Device:
    SPro3
    There are a lot of reasons why the system process is running hot, from bad drivers to an incompatible antivirus. Try running Process Explorer to diagnose the problem.
     
  3. Caesar

    Caesar New Member

    Joined:
    Nov 10, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1

Share This Page

Search tags for this page

system process head surface