This has to go back...

Discussion in 'Microsoft Surface Pro 3' started by liftbikerun, Jun 24, 2014.

  1. liftbikerun

    liftbikerun New Member

    Joined:
    Jun 3, 2014
    Messages:
    51
    Likes Received:
    2
    Trophy Points:
    0
    I'm pretty frustrated right now. I've been going back and forth now for a day or two about possibly returning my SP3. I sold my SP2 losing $400 in the process from when I bought it. I got this, thinking, it would at least perform at a minimum, the same as my SP2.

    I tried installing super street fighter for the heck of it a few ago, and ran the benchmark section about 4 times. Now even with a reboot, for 10+ minutes now my SP3 has been entirely useless. It feels like an old Celeron machine that has been running at 100% for 10 minutes. Windows are choppy, scrolling is all but impossible, the fan is STILL running at full blast, my house is sitting at a chilly 67f (per our AC), and I am using my tablet with the kickstand on a hard lap pad, with full air movement, plugged in the entire time.

    Abysmal, I don't normally complain about this stuff, I take it step by step, but this basically means anytime the fan starts blowing due to a spreadsheet I am working on or an HD video I am presenting with, my computer will come screeching to a halt. It's not acceptable, and I am going to vote with my pocket book and let Microsoft know.

    I absolutely LOVED my SP2, and was SO excited for the more appropriately sized screen for work and writing. But, it looks like I am headed back to the 13" Macbook Air. I'll miss the touch screen, but this is just not happening, I blew $1300 on this, lost $400, and I'm pretty pissed about it.
     
  2. vancamp

    vancamp New Member

    Joined:
    Jun 22, 2014
    Messages:
    15
    Likes Received:
    3
    Trophy Points:
    3
    Check to see if something is still running with 100% CPU in the background.
     
  3. liftbikerun

    liftbikerun New Member

    Joined:
    Jun 3, 2014
    Messages:
    51
    Likes Received:
    2
    Trophy Points:
    0
    AND 20 minutes later it's still choppy to move windows around, the screen isn't recognizing my inputs, etc cause this thing has dropped performance so low to try to cool itself down. It's been 20 minutes without ANY graphics programs open, the only thing going is 1 instance of Chrome to post this, and a tab open to find the nearest Microsoft Store to return this POS
     
  4. Feoen

    Feoen Member

    Joined:
    Jun 24, 2014
    Messages:
    47
    Likes Received:
    29
    Trophy Points:
    18
    If your fan is maxing out due to an Excel spreadsheet or showing HD video, something is wrong. I used this all day with numerous applications open (including over a dozen spreadsheets) and did not hear the fan once. Playing games, yeah, fan goes on full blast, but even then it isn't that loud.

    I have not had any choppy windows or scrolling issues, either. Did you do the firmware update that was available on Day One? If yes and you are still having these issues just running the basic OS, something is seriously wrong.
     
  5. Feoen

    Feoen Member

    Joined:
    Jun 24, 2014
    Messages:
    47
    Likes Received:
    29
    Trophy Points:
    18
    I do have a problem with resizing Chrome windows where it gets to be a choppy resize, but that is literally the only choppiness I have had.
     
  6. liftbikerun

    liftbikerun New Member

    Joined:
    Jun 3, 2014
    Messages:
    51
    Likes Received:
    2
    Trophy Points:
    0
    My CPU is sitting at 4% consistently right now. Been watching it for 5 minutes. It's as if this thing CANT cool down once it heats up. I'm seriously wondering if there isn't a major design flaw with this thing. I was totally going to keep it before this happened and hope for an update, but there is nothing software can do for this fiasco.
     
  7. liftbikerun

    liftbikerun New Member

    Joined:
    Jun 3, 2014
    Messages:
    51
    Likes Received:
    2
    Trophy Points:
    0
    It's any window I move around, I closed down chrome and rebooted and opened up a simple explorer window and it's STILL choppy and the fan is STILL going 100%.
     
  8. Feoen

    Feoen Member

    Joined:
    Jun 24, 2014
    Messages:
    47
    Likes Received:
    29
    Trophy Points:
    18
    OP, if you have the chance to go to a Microsoft Store or a Best Buy, try theirs out. It literally should not be functioning like that. It sounds like you have a lemon.

    I just ran Morrowind for half an hour and my temps got up to 80 degrees and fan was at 100%. I quit it and it went down to 45 degrees with fan not even audible within 3 minutes. The cooling seems to work just fine.
     
  9. liftbikerun

    liftbikerun New Member

    Joined:
    Jun 3, 2014
    Messages:
    51
    Likes Received:
    2
    Trophy Points:
    0
    Up to that point everything was working just fine, I was impressed but, I don't know, I just can't waste $1300 on this thing right now I guess. Definite buyers remorse, I used the ones at best buy before my pre-order got here, and for the last 5 days, this has worked flawlessly. No new updates, no new installed software.

    I just actually shut it down, and restarted and things are somewhat back to normal, but even now, the fan is still on and according the Speccy, the CPU is still sitting at 60C 25 minutes after I shut down the game entirely and started writing these posts.
     
  10. vancamp

    vancamp New Member

    Joined:
    Jun 22, 2014
    Messages:
    15
    Likes Received:
    3
    Trophy Points:
    3
    Check taskmgr to see what's running. Sounds like something is running in the background.
     
    1 person likes this.
  11. benjitek

    benjitek Active Member

    Joined:
    Jan 7, 2014
    Messages:
    622
    Likes Received:
    70
    Trophy Points:
    28
    My Device:
    SPro2
    Just make sure to keep track of your last day of return date in case you decide to wait for the 2nd-gen batch of SP3's ;-)
     
  12. RottenMutt

    RottenMutt Member

    Joined:
    Jun 21, 2014
    Messages:
    54
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Ft Worth
    My Device:
    SPro3
    my fan is quiet or not running, runs smooth, but i do get warnings in event viewer that my speed is being limited in firmware.
     

Share This Page