Touch Cover keystroke sounds muted?

Discussion in 'Microsoft Surface Pro' started by mitchellvii, Apr 15, 2013.

  1. mitchellvii

    mitchellvii Well-Known Member

    Joined:
    Mar 30, 2013
    Messages:
    2,483
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Charlotte, NC
    My Device:
    SPro3
    Yesterday my Touch Cover keystroke sounds muted themselves and won't come back on. I made sure they are turned on in settings and that nothing weird is happening in Sound settings. I did turn on the Loudness Equalization and Surround Sound in my Sound Settings yesterday and thought that may have been it, but I turned them all back off and rebooted and still no sound on keyboard. All other sounds work properly.

    Any ideas?

    P.S., Note to MS if you are listening. Would it be possible to add an option to set keystroke sounds separately from system sounds? If I am listening to music and still want keyboard sounds I don't want the keystroke sounds as loud as the music. Duh, I mean hell, do you actually focus group ANYTHING before you push it out the door? Also how about adding an option for touch sounds when we click a link? This is Android 101 stuff guys. Every time a user does something in Windows 8 where they expect a certain behavior and it doesn't happen it's just another nail in Windows 8 coffin. Do some usability studies people. Geesh.

    Overall Surface Pro is an excellent device but it's the little design fails like these that drive me crazy, probably because MS obviously thinks they are a good idea. Has anyone else noticed how MS is taking control from the user? We can't set event sounds separately, we can't opt out of Modern UI, we can't boot to Desktop, we can't adjust the kickstand, we can't use anything but a hard plastic nib on the pen... we can't, we can't, we can't. Try designing some "we can" into Windows 8 and maybe it will sell.
     
    Last edited: Apr 15, 2013
  2. machistmo

    machistmo Active Member

    Joined:
    Nov 17, 2012
    Messages:
    790
    Likes Received:
    53
    Trophy Points:
    28
    Location:
    Raleigh NC
    My Device:
    Other
    I have the type cover and don't want to hear sounds. Apple had this problem with adjusting volume and it setting everything to level. It was just recently fixed. I agree though, some of this stuff is mind boggling when you think about it.
     
    1 person likes this.
  3. mitchellvii

    mitchellvii Well-Known Member

    Joined:
    Mar 30, 2013
    Messages:
    2,483
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Charlotte, NC
    My Device:
    SPro3
    There are times when I don't want to hear sounds either but i want to make that choice myself. With the type cover you don't need keystroke sounds. That thing sounds like a machine gun if you are a fast typist. I can't imagine sitting in a meeting or class or library typing on it without getting some dirty looks. :)

    In Android they just have a setting under keyboards to adjust the volume of just the keyboard. We need that.
     
  4. heed

    heed New Member

    Joined:
    Mar 18, 2013
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    0
    I had the same problem. I unattached the touch cover and reattached it (while the computer was on at the Modern UI) and now they're back.

    Also, there is a toggle in the "Change PC Settings"->General section.
     
  5. mitchellvii

    mitchellvii Well-Known Member

    Joined:
    Mar 30, 2013
    Messages:
    2,483
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Charlotte, NC
    My Device:
    SPro3
    Tried that, no joy. May be one of the 20 updates MS is putting out every day that messed me up :)
     
  6. tonyz3

    tonyz3 New Member

    Joined:
    Jan 28, 2013
    Messages:
    729
    Likes Received:
    118
    Trophy Points:
    0
    perhaps the foam packing material you put on the back of it is wreaking havoc. :wink:
     
  7. mitchellvii

    mitchellvii Well-Known Member

    Joined:
    Mar 30, 2013
    Messages:
    2,483
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Charlotte, NC
    My Device:
    SPro3
    The .foam virus you mean? No, I don't think so :)

    I went into Sound Settings and reset everything to default and keyboard sounds came back. Who knows?
     
  8. riggi

    riggi Member

    Joined:
    Mar 29, 2013
    Messages:
    147
    Likes Received:
    25
    Trophy Points:
    18
    If I have the onscreen keyboard sounds enabled in the pc settings, when I attach the type cover, there are no sounds when I type on the type cover.
    But, I do agree that the level of the onscreen keyboard sounds should be able to be set separately. I like having the audio feedback when using the onscreen keyboard, but it should be a lot softer than it is. I've tried searching for the sound file used for the onscreen keyboard so I could edit it to reduce the volume, but can't find anywhere on the C: drive.
     
  9. slvrdrgn123

    slvrdrgn123 New Member

    Joined:
    Feb 19, 2013
    Messages:
    45
    Likes Received:
    5
    Trophy Points:
    0
    This happened with my first SP. It went away and wouldn't come back no matter what until I did a reset. Of course the problem came back again so I exchanged for a new SP and it's been working fine ever since. Try to get a new unit if you're still able to.
     

Share This Page

Search tags for this page
mute keystroke sound for surface pro
,
surface keyboard sound off
,
surface pro keyboard make sounds
,

surface pro no sounds touch cover

,
surface pro touch cover no sound
,
surface pro touch cover sounds
,
surface touch cover no sound
,
surface touch cover sound
,
touch cover no sound
,
turn cap sound off in surface pro 2