Touch keyboard popping up after several minutes, partly locking Surface

Discussion in 'Surface Pro 6' started by Mastiff, Apr 25, 2019.

  1. Mastiff

    Mastiff Member

    Joined:
    Nov 25, 2015
    Messages:
    67
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Norway
    My Device:
    Other
    Does anybody else have this? When I touch a text field of some type, the keyboard doesn't come up at once if it's been a while (hours) since I last used it. It takes several minutes, and during that time touch is partly not working. I can't click on web links, and I have to use the scroll bar to move down pages. Also I can't get the start menu up. This is bloody annoying stuff! Is there a fix? It has been this way for a long time. I had the same problem with my Surface Pro (5).
     
  2. leerandall

    leerandall New Member

    Joined:
    Jan 20, 2019
    Messages:
    28
    Likes Received:
    10
    Trophy Points:
    3
    My Device:
    Other
    Yes, I've had this happen with my SP6 as well a few times. There's nothing to do except wait for the touchscreen to become responsive again. For me, the wait time has been anywhere between a few seconds and about a minute.
     
  3. Mastiff

    Mastiff Member

    Joined:
    Nov 25, 2015
    Messages:
    67
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Norway
    My Device:
    Other
    If it was only seconds to a minute it wouldn't be much of a problem, but as I asid it's a lot longer for me. I only use the touch keyboard maybe 2-3 times a week, so it will be days between use, but even when it's less then a day (usually around 20-something hours, I almost only use this when I'm reading in bed before I sleep but I go to sleep at different times) it can take that long.
     
  4. Turbo4AWD

    Turbo4AWD Active Member

    Joined:
    Sep 1, 2015
    Messages:
    313
    Likes Received:
    38
    Trophy Points:
    28
    My Device:
    Other
    Try entering the bios, then using the arrow keys on the keyboard to choose to boot to Windows. See if the issue returns.
     
  5. Turbo4AWD

    Turbo4AWD Active Member

    Joined:
    Sep 1, 2015
    Messages:
    313
    Likes Received:
    38
    Trophy Points:
    28
    My Device:
    Other
    NVM, new firmware came out and the changelog says "fixes Type Cover connection failures". Here's the changelog:


    Surface Pro 6
    • Intel Corporation – Display – 24.20.100.6294: Improves system stability and performance.
    • Intel Corporation – Extension – 24.20.100.6293: Improves the stability and performance of the system.
    • Surface – Firmware – 239.2638.257.0: Improves battery stability, fixes CPU throttling at 400MHz and connection failure with the Type Cover.
    • Surface – System – 3.104.139.0: Improves display color.
    • Surface – System – 6.35.139.0: Improves the stability and performance of the system.
     
  6. Turbo4AWD

    Turbo4AWD Active Member

    Joined:
    Sep 1, 2015
    Messages:
    313
    Likes Received:
    38
    Trophy Points:
    28
    My Device:
    Other
    My Windows Update isn't picking it up yet, but I am sure it will soon. Maybe over the weekend the Firmware Update will be available for my Surface Pro 6. It's not even showing up in my history log either so I don't have the update yet.
     
  7. Mastiff

    Mastiff Member

    Joined:
    Nov 25, 2015
    Messages:
    67
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Norway
    My Device:
    Other
    Nothing helped, until yesterday, when I did the May update. Suddenly it seems the slowdown is gone. I don't much like the new "light" theme on the on screen keyboard, but I'm not touching it now that it works. ;)
     

Share This Page