Touch Screen is Too Often Unresponsive

Discussion in 'Microsoft Surface Pro 4' started by DavidZ, Dec 20, 2015.

  1. DavidZ

    DavidZ Member

    Joined:
    Dec 13, 2015
    Messages:
    151
    Likes Received:
    24
    Trophy Points:
    18
    My Device:
    SPro4
    I'm having a lot of fun playing with and learning my new SP4. This is my first tablet and my first Win 10 PC, so there's a lot to learn.

    By far my biggest frustration (and disappointment) is the unresponsive screen for both touch and the pen. Sometimes when I click on a link, nothing happens. This happens way too often. Then I click on it again and again and, more often than not, something finally happens. I'm pretty sure I made contact each time because I see the screen react to my touch or tap of the pen.

    Is this a software or hardware issue? Or both? Do you think this will be solved with future software updates? Is there something I can do now to make it better?
     
  2. robertcan

    robertcan Member

    Joined:
    Nov 3, 2015
    Messages:
    70
    Likes Received:
    12
    Trophy Points:
    8
    My Device:
    SPro4
    Hi David - I've had this issue to varying degrees since day one. I use the pen probably 90% of the time.It was also present on my first SP4 but that machine was so messed up out of box it ended up being returned and swapped for my current SP4 but they both had this issue.

    I'm not really sure if this is sw/hw or both but I haven't seen any tips related to making it better. Only responding to let you know you're not alone and that I've seen other reports of this issue here and an other forum sites. Just another issue we're all hoping passes with future updates.
     
  3. DavidZ

    DavidZ Member

    Joined:
    Dec 13, 2015
    Messages:
    151
    Likes Received:
    24
    Trophy Points:
    18
    My Device:
    SPro4
    Do the other Surface products suffer from the same problem?
     
  4. pmm0724

    pmm0724 New Member

    Joined:
    Dec 16, 2013
    Messages:
    22
    Likes Received:
    2
    Trophy Points:
    3
    I have the same issue and did not have it on the SP 3.
     
  5. DavidZ

    DavidZ Member

    Joined:
    Dec 13, 2015
    Messages:
    151
    Likes Received:
    24
    Trophy Points:
    18
    My Device:
    SPro4
    Is there anyone with an SP4 who does NOT have this problem? If so, please reply to this thread with your experience and/or observations.
     
  6. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    I'm using i5/8/256 SP4 without the problem you are describing. I have had the HID Driver crash and require a reboot, but that has happened from time to time on every tablet I've used.
     
  7. dman27

    dman27 Active Member

    Joined:
    Jul 1, 2014
    Messages:
    121
    Likes Received:
    26
    Trophy Points:
    28
    I've had the same same issue. This is definitely a SP4 issue more so than previous versions. I swapped out my first SP4 and the second was better until the final update of windows 10 and it started having the same issue. May take this one back in the next couple of weeks as well.
     
  8. DavidZ

    DavidZ Member

    Joined:
    Dec 13, 2015
    Messages:
    151
    Likes Received:
    24
    Trophy Points:
    18
    My Device:
    SPro4
    I wonder if speed is an issue here. When I click on a link sometimes nothing happens. And sometime something happens, but there's a delay. The problem with the latter is that there's no user feedback, so I don't know if the computer is nonresponsive or just slow. As a result, I click again and sometimes end up with multiple windows or tabs open. Perhaps if the software gave me some kind of immediate feedback (e.g., an hourglass, etc.), I would just relax and wait for it to respond. I found the little circle of blue dots in the upper left corner of Edge, but there's often a delay before that starts circling.

    I also wonder if 8GB RAM is better for this issue because it doesn't have to go out to the SSD as often.

    In any event, my main concern is whether the problem is software related or hardware related. If it's software related, then I suspect MS will eventually fix it. If it's hardware related, that's a big problem that may be unsolvable.
     
  9. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    It is most likely caused by the Smart Filter....
     
  10. DavidZ

    DavidZ Member

    Joined:
    Dec 13, 2015
    Messages:
    151
    Likes Received:
    24
    Trophy Points:
    18
    My Device:
    SPro4
    What is "the Smart Filter?" I did a quick search and it appears to be some software on the server end. How would that be the cause of this problem? Please elaborate.
     
  11. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    The Smart Filter examines/assesses where links are from and potential risks of said links....
     
  12. DavidZ

    DavidZ Member

    Joined:
    Dec 13, 2015
    Messages:
    151
    Likes Received:
    24
    Trophy Points:
    18
    My Device:
    SPro4
    OK, thanks.

    If the Smart Filter is the culprit, then why is only the SP4 affected by this problem? I presume that the Smart Filter resides on other touch devices, correct?
     

Share This Page