Touchpad lag on first touch. Can it be fixed?

Discussion in 'Microsoft Surface Pro 3' started by baandoptager, Jan 10, 2015.

  1. baandoptager

    baandoptager New Member

    Joined:
    Nov 3, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    So.... Whenever i browser around and come back to the touchpad (Type cover), it never reacts well on first touch. It won't just start moving, as if it is waiting for the cursor to pop up first?

    I've turned of the delay in the touchpad settings. So i really don't get why this is like this.

    Couldn't find it in the forums. Has anyone noticed? Isn't it annoying?

    Can we fix this?
     
  2. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,693
    Likes Received:
    422
    Trophy Points:
    83
    Haven't experienced anything along the lines of that on my type cover
     
  3. Liam2349

    Liam2349 Active Member

    Joined:
    Aug 2, 2014
    Messages:
    884
    Likes Received:
    132
    Trophy Points:
    43
    My Device:
    SPro3
    I think I know what you're talking about. When using the trackpad, the cursor doesn't move until you've moved your finger a certain distance. Until you've moved it a certain distance, nothing will register. After you've hit this threshold, the smallest movements are picked up just fine.

    I think it's a feature to prevent accidental input, however I would love a way to disable it.
     
  4. phositadc

    phositadc Member

    Joined:
    Aug 24, 2014
    Messages:
    100
    Likes Received:
    4
    Trophy Points:
    18
    There is an option in mouse settings to disable the delay. I don't have my sp3 with me right now so I can't point you to it exactly, but it's there in the metro ui settings if you go to mouse settings.
     
  5. olimjj

    olimjj Active Member

    Joined:
    Mar 27, 2013
    Messages:
    550
    Likes Received:
    113
    Trophy Points:
    43
    Location:
    Where no man has gone before.
    My Device:
    SPro3
    @phositadc is correct. In Start Screen, activate Charm Bar, Settings, Change PC settings, Mouse and touchpad. The last item in the list has the delay settings.
     
  6. baandoptager

    baandoptager New Member

    Joined:
    Nov 3, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    As pointed out in the actual post, these settings have been disabled and it doesn't work. I've tried on another pro 3, same thing.
     
  7. baandoptager

    baandoptager New Member

    Joined:
    Nov 3, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    Exactly! I absolutely hate it!
     
  8. herrkjeldsen

    herrkjeldsen New Member

    Joined:
    Feb 18, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Same here
     
  9. stylo

    stylo New Member

    Joined:
    Feb 24, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Same for me, I did a video showing how much i can move my finger until the pointer reacts !!! It's way too much.



    I wish someone could give a trick with a registry modd to prevent this delay.
     
  10. stylo

    stylo New Member

    Joined:
    Feb 24, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
  11. JME401

    JME401 New Member

    Joined:
    Sep 25, 2014
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    I saw this a while back here. The not so elegant solution is to disable the "Microsoft Input Configuration Device" under Human Interface Devices in the Device Manager. You then have to detach and reattach the keyboard to take affect.

    The down side is you loose trackpad features like two finger scroll, two finger tap right click.

    [​IMG]
     
  12. herrkjeldsen

    herrkjeldsen New Member

    Joined:
    Feb 18, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Just found this. I can do without the two finger scroll, if it means getting an actual useable trackpad. This works a charm! Thank you very much jme401!
     

Share This Page

Search tags for this page
surface 3 touchpad is lagging
,

surface 4 touchpad lag

,
surface 4 touchpad touch
,
surface 4 trackpad delay
,

surface pro 3 touchpad lag

,
surface pro 4 touchpad delay
,
surface pro trackpad lag after typing
,
touch on surface pro 4 lag
,
touchpad lag surface pro 3
,

touchpad lag windows 10