Solved Touchpad SO finicky

Discussion in 'Microsoft Surface Book' started by ElectricHops, Dec 30, 2015.

  1. ElectricHops

    ElectricHops New Member

    Joined:
    Dec 30, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface Book
    I was so excited to dump my macbook air for the SB and I've been mostly happy with the decision. My biggest gripe is that the keyboard and touchpad randomly stop working.

    Does anyone else have the following issue? When placing two fingers on the touchpad to scroll, there is a delay in the start of the scrolling. This doesn't always occur, but probably 20% of the time there will be a touchpad delay when lightly sliding two fingers up or down.
     
  2. mtmowl

    mtmowl Member

    Joined:
    Oct 28, 2015
    Messages:
    83
    Likes Received:
    5
    Trophy Points:
    8
    My Device:
    Surface Book
    Yes, the same frustrating problem. I go from no response to zooming past the target in the blink of an eye.
     
  3. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    2,854
    Likes Received:
    1,030
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    That's not good, and not the way it should be working for you.
    I use my MacBook Retina 15 computers as often as the Surface Book. Response on both is perfect.

    So let's try to get you some help.
    What version of Windows 10 are you running (Settings, System, About).

    I am running:
    Windows 10
    Version 1511
    OS Build 10586.36

    Mouse and touchpad Settings: Screenshot (1).png
     
  4. Sher the Love

    Sher the Love Member

    Joined:
    Oct 16, 2013
    Messages:
    121
    Likes Received:
    11
    Trophy Points:
    18
    I have an issue where taps to click don't register. It generally happens on links in web browsers. If I tap off the link on something like text then click back on the link, it works. Fully pressing the touchpad always works as a click, but taps are another story...

    Edit: I should mention this happens far more often in Chrome. In happens once in a while in Edge.
     
    Last edited: Dec 30, 2015
  5. mtmowl

    mtmowl Member

    Joined:
    Oct 28, 2015
    Messages:
    83
    Likes Received:
    5
    Trophy Points:
    8
    My Device:
    Surface Book

    Thanks. I'm running the same on a WB i5/8/256. The scrolling seems to have a delay before moving, especially the upon first touch. I'm guessing that's the nature of the device, though. The real problem seems to be that the two-finger scrolling switches into pinch-to-zoom all too easily, and I'm forever trying to resize the screen. Any ideas on a remedy? I'm already trying to keep my two fingers side-by-side to control any pinching. Maybe a sensitivity setting?

    Thanks again.

    Here's my touchpad info:


    upload_2015-12-31_7-4-17.png upload_2015-12-31_7-4-44.png
     

    Attached Files:

  6. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    2,854
    Likes Received:
    1,030
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    Try matching my settings, and see if you still have the same problem.
     
  7. mtmowl

    mtmowl Member

    Joined:
    Oct 28, 2015
    Messages:
    83
    Likes Received:
    5
    Trophy Points:
    8
    My Device:
    Surface Book
    Even with matching settings, I still get unpredictable pinch/zooming. Can that be set to a lower sensitivity somewhere?
     
  8. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    2,854
    Likes Received:
    1,030
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    What app are you scrolling? Edge Browser? Try other apps and programs to see if the same issue exists.
     
  9. mtmowl

    mtmowl Member

    Joined:
    Oct 28, 2015
    Messages:
    83
    Likes Received:
    5
    Trophy Points:
    8
    My Device:
    Surface Book
    I'm using Firefox. Just reading around, it seems a lot of people have the same "zooming" problem.
     
  10. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    2,854
    Likes Received:
    1,030
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    Ahhh.
    The problem is Firefox.
    Just verified that on my own Surface Book.

    Try another app like Wordpad or Notepad or Edge Browser. You should not see this problem.
     
  11. Niterider4

    Niterider4 Active Member

    Joined:
    Oct 29, 2015
    Messages:
    173
    Likes Received:
    54
    Trophy Points:
    28
    My Device:
    Surface Book
    I have the same issue with scrolling in Firefox. Sometimes when I scroll with two fingers, there is a delay and I have to try again. Not sure if it happens in other programs - I'll have to see.
     
  12. mtmowl

    mtmowl Member

    Joined:
    Oct 28, 2015
    Messages:
    83
    Likes Received:
    5
    Trophy Points:
    8
    My Device:
    Surface Book
    That's it. I checked it out on Edge, and find scrolling much smoother and controllable. I might switch everything to Edge until Mozilla gets Firefox straightened out.

    Thanks again.
     

Share This Page