trackpad constantly freezing up

Discussion in 'Microsoft Surface Pro 3' started by kiwigirl, Oct 26, 2014.

  1. kiwigirl

    kiwigirl Member

    Joined:
    Oct 24, 2014
    Messages:
    152
    Likes Received:
    17
    Trophy Points:
    18
    First off, I have to say the trackpad is garbage. Its not total garbage but coming from a Mac trackpad, this is not even in the same universe. My biggest complain about it is that its too short height wise and that it is always freezing up! The cursor will move but the scrolling doesnt work for a few secs here and there.

    Does anyone else have this problem? Apparently its really common even going all the way back to the 1st gen surface and MS has yet to fix them. I had this problem on the first keyboard i had too, just two days ago and I exchanged that.
     
  2. Aurelio

    Aurelio Member

    Joined:
    Sep 22, 2014
    Messages:
    65
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    São Paulo
    My Device:
    SPro3
    I love the magictrackpad, so for me is difficult also to use the trackpad in the type cover!

    About the delay.... Have one option that you can set for ZERO the delay (or something like that), normally they have by default one short delay to avoid that you "click" by mistake!
     
  3. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,332
    Likes Received:
    1,279
    Trophy Points:
    113
    AFAIK nobody has ever made a decent Windows trackpad. :(

    this one is definitely hampered by size.
     
  4. kiwigirl

    kiwigirl Member

    Joined:
    Oct 24, 2014
    Messages:
    152
    Likes Received:
    17
    Trophy Points:
    18
    how do you do this?

    The device is otherwise-stellar.lam willing to forgive microsoft. just have to carry my 3 button mouse.
     
  5. Telstar1948

    Telstar1948 Active Member

    Joined:
    Jul 12, 2013
    Messages:
    435
    Likes Received:
    78
    Trophy Points:
    28
    Location:
    Columbia, Missouri
    My Device:
    Surface Book
    Swipe in from right > Settings > Change PC Settings > PC and devices > Mouse and touchpad > all the way to the bottom, delay setting for touchpad
     

Share This Page

Search tags for this page

surface 3 trackpad freeze

,

surface pro 4 touch pad freezes

,

surface pro 4 touch pad freezing

,

surface pro 4 touch pad keeps freezing

,

surface pro 4 trackpad freezes

,

surface pro 4 trackpad freezing

,

touchpad surface book freezes