Trackpad gesture issue after February update

Discussion in 'Microsoft Surface Pro 2' started by S-tension, Feb 17, 2014.

  1. S-tension

    S-tension New Member

    Joined:
    Jan 13, 2014
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
  2. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    Hmm works fine for me. Did you try and restart your computer?
    Does it happen when you do Win+Tab as well?
     
  3. S-tension

    S-tension New Member

    Joined:
    Jan 13, 2014
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    Well yes restarting fixes the issue but it will probably come back. Overall gestures got worse after the update.
     
  4. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    Ok dude, you just got a Windows bug, calm down.
    When it will come back again, then we will see (my guess it's a software you installed that screwed up Windows that specific time).

    It works fine for everyone.
     
    Last edited: Feb 17, 2014
  5. DNP

    DNP Member

    Joined:
    Jan 21, 2014
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    My Device:
    SPro2
    For me, I wouldn't say the touchpad issues have become worse after the Feb update; however, it still didn't seem to resolve the issues related to losing the type cover connectivity and then needing to use the detach/reattach feature. That feature-problem-bug needs some attention before the hinges on type covers wear out.
     
  6. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    DNP did you try replacing your keyboard? It could be faulty.
    For me it only happened once... but I am still debating if it was a miss snap in situation, as I can't replicate the issue.
    And device manager did have a "!" mark on the Type Cover 2.
     
  7. DNP

    DNP Member

    Joined:
    Jan 21, 2014
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    My Device:
    SPro2
    Hello GoodBytes...yes, I returned my first Type Cover 2, but the second one has the same enhanced feature. I've also "tested" several other SP2's with Type Cover 2's and was able to replicate one particular power setting configuration that will disable the touchpad (or re-enable the feature...whichever way MS wants to look at these things). The techs agreed that it's a problem and may be driver related? If you want you can give the following a shot to see if you have the same results:

    1) In the desktop mode open the Internet Explorer and confirm the touchpad gestures are working correctly by using the two-finger scroll or swipe-in from the right side to show the charms (if the touchpad gestures are not working detach and reattach the keyboard and redo step #1). I also have the page scrolling reversed so that should also be operating correctly.
    2) When the touchpad gestures are working correctly go to Control Panel>Power Options.
    3) Select “Choose what closing the lid does”.
    4) Set “When I close the lid” to “Do Nothing” for when Plugged In.
    5) Save the selected power options.
    6) Plug-in the Surface (if not already).
    7) Close the Type Cover 2 and leave closed for a few moments (about 10 seconds or more). The Surface should not go into Sleep mode.
    8) Open the Type Cover 2 to reactivate the keyboard.
    9) Open Internet Explorer and check if the touchpad gestures are operating correctly or have been disabled.
    10) If the touchpad gestures are not working correctly detach and reattach the keyboard.
    11) The touchpad gestures should now be reactivated.

    I had thought this had been resolved after the Feb. patch, but it still works this way for me. Unfortunately, this is currently the way I would like to have the power settings configured.


    Thanks for the interest.
     
  8. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    Aha I see. The scrolling still works, but not the left and right gestures (which I have disabled normally, but did not for this test).
    Interesting.
     
  9. kundas1

    kundas1 Super Moderator Staff Member

    Joined:
    Dec 4, 2013
    Messages:
    1,653
    Likes Received:
    299
    Trophy Points:
    83
    My Device:
    SPro3
    why are you telling him to calm down? his post isn't over dramatic or anything.... lol what am I missing?
     
  10. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    To me he sounds like freaking out for an issue that is not related to the firmware.
     
  11. kundas1

    kundas1 Super Moderator Staff Member

    Joined:
    Dec 4, 2013
    Messages:
    1,653
    Likes Received:
    299
    Trophy Points:
    83
    My Device:
    SPro3
    I don't see how you perceive that, but ok lol amazing how we perceive things differently on the web lol
     
  12. bluegrass

    bluegrass Well-Known Member

    Joined:
    Nov 11, 2013
    Messages:
    1,304
    Likes Received:
    193
    Trophy Points:
    63
    Location:
    St. Louis, Mo
    My Device:
    SPro3
    Get a Bluetooth mouse. That will solve all the issues with the touchpad. I support quite a few user with touchpads on their laptops and none of them who travel would consider using the touch pad. They all carry mice. Me too.
     

Share This Page

Search tags for this page

surface pro 3 trackpad issue