Two issues: Need Help

Discussion in 'Microsoft Surface Book' started by Gizmo2005, May 15, 2018.

  1. Gizmo2005

    Gizmo2005 New Member

    Joined:
    May 15, 2018
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface Book
    I have a Surface Book 2 (Core i5, 8gb, 256ssd). I have had it for two months now and have noticed two problems so far:

    1. When I go from work to home (or from home to work), the wifi doesn't automatically connect to each location. It always says, "Connected, but no internet access". To get this to work, I have to restart each time. Pain in the butt, but it also works.
    2. I can't power on with battery around 30%. If I connect the power cable, I can. But other wise, I push down the Power button and it does nothing.
    Please help.

    Thanks-
     
  2. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,872
    Likes Received:
    1,870
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Are you running the latest Firmware Updates? Is your Windows 10 up to date? These were bugs that manifested last January and were fixed by February's updates IIRC.
     
  3. Gizmo2005

    Gizmo2005 New Member

    Joined:
    May 15, 2018
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface Book
    Updating now. I'll see how it works afterwards. Thanks.
     
  4. Gizmo2005

    Gizmo2005 New Member

    Joined:
    May 15, 2018
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface Book
    I did all the latest updates last week:

    Yesterday, I was at work and everything was working fine. At 5pm, I closed the lid, put the SB in my bag and took it home. Later on that night, I opened the SB, it turned on, but the internet wasn't available. There was no exclamation mark on the internet icon (lower right). but there was no internet. It showed it connected to my network. I had to restart to get it to work. Please help. This is a pain in the rear. Wondering if it's something in the settings.

    FYI...when I hover my mouse over the internet icon on the lower right this is what I see:

    Name of network
    Internet Access


    Unidentified Network
    No Internet Access

    This morning. Same thing. Opened up the laptop, it shows the SB connected to my work's network, but no internet. No yellow exclamation. It's connected. But no internet.
     
    Last edited: May 23, 2018
  5. Wayne Orwig

    Wayne Orwig Active Member

    Joined:
    Mar 18, 2013
    Messages:
    391
    Likes Received:
    47
    Trophy Points:
    28
    I think I would try going through all of the WiFis and forgetting them. Then reconnecting the ones you need.
     
  6. bangsters

    bangsters Member

    Joined:
    Apr 15, 2013
    Messages:
    168
    Likes Received:
    15
    Trophy Points:
    18
    Hey. That has happened to me a few weeks back. I deleted my home network, and re-added it, after installing windows updates. so far hasn't happened again.

    Hope this helps.
     
  7. Gizmo2005

    Gizmo2005 New Member

    Joined:
    May 15, 2018
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface Book
    Yeah..but I can't delete my work network. I can only press 'forget/cancel'.
     
  8. bangsters

    bangsters Member

    Joined:
    Apr 15, 2013
    Messages:
    168
    Likes Received:
    15
    Trophy Points:
    18
    Yes that's what I meant, forget the network. Then re-add it.
     

Share This Page

Search tags for this page
azs
,

best cameras

,

news