Type 2 cover keys not mapped correctly

Discussion in 'Microsoft Surface Pro 2' started by busanga, Jun 6, 2014.

  1. busanga

    busanga New Member

    Joined:
    May 3, 2014
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    0
    The specialized keys on my type 2 cover are not mapped correctly. I don't know when this happened they used to work fine. Anybody come across this problem
     
  2. daniielrp

    daniielrp Active Member

    Joined:
    Oct 26, 2013
    Messages:
    693
    Likes Received:
    133
    Trophy Points:
    43
    Location:
    Preston, UK
    My Device:
    SPro3
    What are they doing? Or not doing?
     
  3. busanga

    busanga New Member

    Joined:
    May 3, 2014
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    0
    Doing different things for example the mute sound button brings up the search function, can't tell what search function is now doing, just makes the desktop flash as if its doing something
     
  4. Nuspieds

    Nuspieds Active Member

    Joined:
    Feb 24, 2013
    Messages:
    774
    Likes Received:
    120
    Trophy Points:
    43
    Location:
    Los Angeles
    My Device:
    Surface Book
    What about the regular keys, like A-Z, 0-9, etc.? Are they messed up as well?

    Anyway, shutdown and restart hasn't helped?
     
  5. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    Open the Ease of Access Center panel. You have a or some options related to keyboard that are enabled. Make sure that absolutely every check box are unchecked.
    That should fix your problem. You may need to restart.

    If your F1 key, on the desktop, shows Windows Help, and doesn't reduce the keyboard brightness, and it a behavior that you want. Do Fn+Caps Lock, this will reverse the keys role, whre now teh keys will do what they are saying, but if you want the F# key, you can just hit Fn+F#.

    If the keyboard keys all all wrong, like A does something else, it is probably you switch to Dvorak keyboard, and not QWERTY one (standard keyboard that 99.99% of the people uses). To fix this, open the Language panel (you can find it in the classic control panel), and from there, click on "Options" on the language you use, then click on "Add an input method", and select QWERTY, of your language of your keyboard. Once done, click on "Add", and then remove the existing DVORAK keyboard that should be listed. Once done restart your system, and you should be good.
     
    Last edited: Jun 6, 2014
  6. busanga

    busanga New Member

    Joined:
    May 3, 2014
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    0
    Thanks goodbyes that seems to have worked
     

Share This Page

Search tags for this page

keys not mapped properly

,

microsoft account password keyboard not mapped correctly

,

surface 3 keyboard keys mapped wriong

,

surface touch cover function keys not mapped correctly

,

whats mapped cover

,

windows surface keys not mapped properly