Type cover not being recognised.

Discussion in 'Microsoft Surface Pro 3' started by emma_king, Feb 18, 2016.

  1. emma_king

    emma_king New Member

    Joined:
    Feb 18, 2016
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro3
    Around Christmas my type cover began to have problems being connected and I would have to disconnect it and reconnect it or sometimes restart my sp3 to get it working again. Then it stopped working all together. The only thing that I havent tried to do myself is do a factory reset. I have also tried buying a new trype cover and the new one wouldnt be recognised as a device and work either.
     
  2. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Welcome to the forum

    Have you applied ALL the updates with the type cover attached?
     
  3. emma_king

    emma_king New Member

    Joined:
    Feb 18, 2016
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro3
    So far as I can tell. It tells me that there are no more updates.
     
  4. ScottyS

    ScottyS Active Member

    Joined:
    Apr 14, 2013
    Messages:
    672
    Likes Received:
    116
    Trophy Points:
    43
    Location:
    New York
    My Device:
    SPro3
    Sounds just like what I have too. It worked after the System Firmware Update - ‎1/‎19/‎2016 for a few days and (after another update) stopped again.
    Haven't tried a reset yet, but I'm not sure that will un-do a firmware change.
     
    emma_king likes this.
  5. PCAnyWhere

    PCAnyWhere Member

    Joined:
    Dec 23, 2014
    Messages:
    57
    Likes Received:
    11
    Trophy Points:
    8
    Location:
    Toronto, Canada
    My Device:
    SPro3
    I was just about to post a question about this. I have a SP3 and was happily using the SP3 Type Cover; until the SP4 new Type Cover came out and got rave reviews. So I snatched one up and in the last 2 months I have experienced situations where when the screen is locked (power connected) or when I purposely put it to sleep with the power button (power may be connected but also not). Upon return the keyboard is unresponsive. I have found that disconnecting it and reconnecting it does the trick most of the time but there is some delay before it is recognized. I did one short test with my old SP3 type cover and it appeared to resolve it; but it was a limited test and I need to do a longer term one.
     
  6. Telstar1948

    Telstar1948 Active Member

    Joined:
    Jul 12, 2013
    Messages:
    435
    Likes Received:
    78
    Trophy Points:
    28
    Location:
    Columbia, Missouri
    My Device:
    Surface Book
    Don't know about the SP4 cover situation, but my SP3 had stopped recognizing the SP3 type cover. Took both to Best Buy. Tried a different type cover with my SP3 and tried my type cover with a different SP3. My type cover worked fine with other SP3's, but my SP3 wouldn't recognize any type cover. It was a SP3 hardware problem that just happened one day out of the blue. Exchanged the SP3 through MS and that replacement is working fine with my original type cover.
     
  7. emma_king

    emma_king New Member

    Joined:
    Feb 18, 2016
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro3
    Disconnecting and reconnecting my type cover used to work, but after the second update it stopped working.
     
    PCAnyWhere likes this.
  8. ScottyS

    ScottyS Active Member

    Joined:
    Apr 14, 2013
    Messages:
    672
    Likes Received:
    116
    Trophy Points:
    43
    Location:
    New York
    My Device:
    SPro3
    I just had to do a full reset (back to factory condition) and that did not fix the type cover no working.
    Everybody who's reporting this problem noticed it around Christmas time; I'm convinced it was a firmware update that did it in.
     
    PCAnyWhere likes this.

Share This Page

Search tags for this page

surface type cover not recognised