Video Very Laggy Now with latest Updates?

Discussion in 'Windows 10 on Surface Pro 3' started by SeanP, Sep 4, 2015.

  1. SeanP

    SeanP Member

    Joined:
    Nov 25, 2014
    Messages:
    90
    Likes Received:
    9
    Trophy Points:
    8
    I use the Netflix app a lot for SP3. Prior to the latest round of updates, when watching any movies on Netflix, it was butter smooth. I had zero issues.

    Now, every 1 min or so the video stutters. It happens over and over again.

    Has anyone else experienced this using the Netflix app? Anyone use the Netflix app? It's extremely annoying and I don't want to use the browser to watch since the resolution for the app is much better and the battery life is much better. My SP3 doesn't heat up with the app but does when I use it in browser with Edge or IE.

    Thoughts?
     
  2. stijn2k6

    stijn2k6 New Member

    Joined:
    Aug 5, 2015
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Same here with the browser version. Not just netflix is slow, everything is...
     
  3. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,340
    Likes Received:
    1,279
    Trophy Points:
    113
    Yup, can hardly stay connected... opening a second Edge tab seems to kill it.
     
  4. theveterans

    theveterans Member

    Joined:
    Feb 7, 2015
    Messages:
    193
    Likes Received:
    15
    Trophy Points:
    18
    No issues here with WiFi on latest updates
     
  5. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,340
    Likes Received:
    1,279
    Trophy Points:
    113
    You must have the Router they tested with. :)
    A year ago when everyone (except you & I) was having problems mine was working fine. Starting around last May or June my SP3 started getting wifi issues ... after the most recent update it's in the toilet even as compared to a couple days ago. I think they are chasing their tails. Too bad the SP4 still uses the same chipset, I was at Best Buy yesterday and confirmed in device manager it has the Not-Marvell-ous adapter. ;)
     
  6. theveterans

    theveterans Member

    Joined:
    Feb 7, 2015
    Messages:
    193
    Likes Received:
    15
    Trophy Points:
    18
    I fairness, I bought Linksys WRT1900ACv1 about 2 months before I bought the SP3. I did know that the Linksys had a Marvell chipset like the SP3 which pretty much make for best compatibility with Surfaces.

    I just did a ping stability test from my sp3. I pinged my Linksys WRT1900AC 300 times to check for packet loss and ping spikes while I use pingtest.net website for jitter test. My WiFi performs as it should on these test with latest updates:

    http://www.pingtest.net/result/132902621.png

    Ping Stability.PNG
     
  7. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,340
    Likes Received:
    1,279
    Trophy Points:
    113
    Put some payload in those ping packets... :)
     
  8. theveterans

    theveterans Member

    Joined:
    Feb 7, 2015
    Messages:
    193
    Likes Received:
    15
    Trophy Points:
    18
    Streaming 4K video while pinging test (buffering about 120 Mbps YouTube speed stream). Still 0 ms ping average (99% 0-1 ms ping) and highest ping of 19ms during the whole 4K stream test. ZERO dropped frames per YouTube Geekstats to boot!

    Happily enjoying my perfect WiFi here :)

    Middle of test:
    Capture.PNG
    End of test:
    Capture.PNG
     

Share This Page