Virtual keyboard is inconsistent

Discussion in 'Microsoft Surface Pro 4' started by stodge, Jan 10, 2018.

  1. stodge

    stodge New Member

    Joined:
    Jan 10, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    I'm curious to see if anyone else has the same problems that I had when using the virtual keyboard with Microsoft Edge.

    I played around with various Windows 10 based 2 in 1s at the store and stumbled across a Surface Pro bundle (a Surface Pro 4 I think, 7th gen Intel?) that includes the keyboard for a good price. So I picked it up. After two hours of updates it was ready so I started logging into the various sites that I use. Except I put the Surface away in frustration because the virtual keyboard just doesn’t work.

    Let me explain. If I click the URL bar (tablet mode without the keyboard attached), the virtual keyboard doesn’t always appear. Sometimes I have to tap twice.

    Once the page has loaded, the virtual keyboard doesn’t disappear, even though no input fields on the page are selected. So I have to close it manually.

    When I try to log into the BoardGameGeek website, when I tap the username field, the keyboard doesn’t appear, even when I tap several times. When I tap the password field, it appears. When I then tap the username field, the virtual keyboard disappears.

    If I tap the URL bar and the virtual keyboard appears, it doesn't disappear when I tap say the page background. In my opinion, it should disappear as no input box is selected.

    Have you experienced this if so, is it something you just learn to live with?

    Thanks
     
    Last edited: Jan 10, 2018
  2. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    3,113
    Likes Received:
    471
    Trophy Points:
    83
    My Device:
    SPro4
    Hi Stodge, welcome.

    It would help to know what browser you are using. As far as I'm aware, it is the browser which dictates how the keyboard works. I occasionally experience this with Chrome when there has been a windows update and google are yet to update chrome to account for the changes within windows. Other than that though, I can't recall experiencing this kind of problem.
     
  3. stodge

    stodge New Member

    Joined:
    Jan 10, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Damn, sorry. I had it in my mind to mention that I was using Edge but I completely forgot to include it! I modified my original post to include this fact. Thanks!
     
  4. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    3,113
    Likes Received:
    471
    Trophy Points:
    83
    My Device:
    SPro4
    In which case I'm afraid I am unable to help as I refuse to use that buggy browser :) Try giving chrome a try just to see if the issue occurs with that as well.
     
  5. stodge

    stodge New Member

    Joined:
    Jan 10, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Hmm, good point, I didn't try any other browsers. Any comments from others about the virtual keyboard with Chrome?
     

Share This Page