Wifi coming back from hibernate?

Discussion in 'Microsoft Surface Pro 3' started by goodintentions, Dec 28, 2014.

  1. goodintentions

    goodintentions Active Member

    Joined:
    Jun 20, 2012
    Messages:
    386
    Likes Received:
    78
    Trophy Points:
    28
    I've been updating my i5 sp3 to the latest everything since yesterday. So far, I really like how well made this thing is. Visual studio is working great on it.

    One thing I've noticed is coming back from hibernate even though WiFi is connected there's no internet. I have to disconnect and reconnect to get it working again.

    It's not that much of a hassle, but anyone know how I can resolve this?
     
  2. goodintentions

    goodintentions Active Member

    Joined:
    Jun 20, 2012
    Messages:
    386
    Likes Received:
    78
    Trophy Points:
    28
  3. ctitanic

    ctitanic Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    2,194
    Likes Received:
    577
    Trophy Points:
    113
    Location:
    Hollywood, FL
    My Device:
    SPro3
    You need to disable Hyper-V to fix this issue.
     
  4. JimB

    JimB Member

    Joined:
    Aug 11, 2014
    Messages:
    82
    Likes Received:
    6
    Trophy Points:
    8
    No solution for this problem. you'll need to create a task scheduler event, triggering this custom event filter:

    <QueryList>
    <Query Id="0" Path="System">
    <Select Path="System">*[System[Provider[@Name='Microsoft-Windows-Power-Troubleshooter'] and (Level=4 or Level=0) and (EventID=1)]]</Select>
    </Query>
    </QueryList>

    Create this .cmd in a text file and execute:

    netsh int set int wi-fi disabled
    netsh int set int wi-fi enabled
     
  5. ctitanic

    ctitanic Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    2,194
    Likes Received:
    577
    Trophy Points:
    113
    Location:
    Hollywood, FL
    My Device:
    SPro3
    Again, the user has Visual Studio installed and that enables Hyper-V. Once Hyper-V is enabled the Wifi will fail when coming back from Hibernation, it's a known issue.
     
  6. JimB

    JimB Member

    Joined:
    Aug 11, 2014
    Messages:
    82
    Likes Received:
    6
    Trophy Points:
    8
    I also have visual studio installed and hyper v is disabled so there are other factors causing this.
     
  7. ctitanic

    ctitanic Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    2,194
    Likes Received:
    577
    Trophy Points:
    113
    Location:
    Hollywood, FL
    My Device:
    SPro3
    Are you sure?
    Try this

    bcdedit /set hypervisorlaunchtype off

    Restart and check if you still have the issue.
     
  8. JimB

    JimB Member

    Joined:
    Aug 11, 2014
    Messages:
    82
    Likes Received:
    6
    Trophy Points:
    8
    Just did the above command, rebooted and same issue. wifi showing connected yet not working.
     
  9. goodintentions

    goodintentions Active Member

    Joined:
    Jun 20, 2012
    Messages:
    386
    Likes Received:
    78
    Trophy Points:
    28
    Disabling hyper-v solved this issue for me. Many thanks.
     
  10. ctitanic

    ctitanic Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    2,194
    Likes Received:
    577
    Trophy Points:
    113
    Location:
    Hollywood, FL
    My Device:
    SPro3
    Are you using the last Wifi Driver?
     
  11. JimB

    JimB Member

    Joined:
    Aug 11, 2014
    Messages:
    82
    Likes Received:
    6
    Trophy Points:
    8
    Yes, 15.68.3066.135 10/29/2014 Marvell Semiconductor. Inc.
     
  12. ctitanic

    ctitanic Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    2,194
    Likes Received:
    577
    Trophy Points:
    113
    Location:
    Hollywood, FL
    My Device:
    SPro3
    What router are you using? If it's a dual band are you using the same SSID? If that's the case, try using different SSID?
     

Share This Page