Wifi Driver failure within an hour after 8.1 update on Surface Pro

Discussion in 'Windows 8 Forum' started by curney, Oct 18, 2013.

  1. curney
    Offline

    curney Member

    Joined:
    Feb 7, 2013
    Messages:
    53
    Likes Received:
    4
    Trophy Points:
    8
    Hi,
    about an hour after i updated to 8.1 my wifi broke. Im getting ""This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)" in the device manager for the Marvell Avastar 350N. I got the most current driver .cab file (versi14.69.24040.136) from another thread on here, put it on the desktop and tried loading it but I get the message that it is up to date and it doesnt help. Any thoughts?

    Thanks!!
    Curney
  2. mitchellvii
    Offline

    mitchellvii Well-Known Member

    Joined:
    Mar 30, 2013
    Messages:
    1,747
    Likes Received:
    349
    Trophy Points:
    83
    Location:
    Charlotte, NC
    My Device:
    SPro3
    Uninstall the Marvell Adapter in Device Manager and select "delete driver software". Then once it is gone from your device list right click the Network Adapters heading and tell it to search for new hardware. The adapter will reappear then update it to the drivers you downloaded.
  3. mitchellvii
    Offline

    mitchellvii Well-Known Member

    Joined:
    Mar 30, 2013
    Messages:
    1,747
    Likes Received:
    349
    Trophy Points:
    83
    Location:
    Charlotte, NC
    My Device:
    SPro3
    I'm not having your issue but since upgrading to 8.1 final I can only get half the data speed I used to get. Have tried everything. Very frustrating.
  4. curney
    Offline

    curney Member

    Joined:
    Feb 7, 2013
    Messages:
    53
    Likes Received:
    4
    Trophy Points:
    8
    Thank you! that worked

    how do you check the speed?
    1 person likes this.
  5. mitchellvii
    Offline

    mitchellvii Well-Known Member

    Joined:
    Mar 30, 2013
    Messages:
    1,747
    Likes Received:
    349
    Trophy Points:
    83
    Location:
    Charlotte, NC
    My Device:
    SPro3
    Open Speedtest.net by Ookla - The Global Broadband Speed Test in any browser and run it. I found out what was killing my speed. Running a bluetooth mouse while on wifi will mess your speed up something awful.

Share This Page

Search tags for this page
avastar surface pro 1 driver is not working properly
,
code 31 marvell avastar wireless composite device
,
marvell avastar 350n driver
,

marvell avastar code 31

,
marvell avastar driver not working properly
,
marvell avastar surface pro fail
,
marvell avastar wireless composite device driver
,
marvell avastar wireless composite device surface cannot load the drivers code 31
,
marvell surface driver problem
,
microsoft surface pro marvell avastar wireless composite device not working properly code 31
,
surface avastar driver
,
surface marvell avastar windows cannot load drivers required code 31
,
surface marvell load the drivers
,
surface pro marvel driver load error
,

surface pro marvell avastar code 31

,
surface pro marvell avastar wireless device
,
surface pro wifi cannot load driver
,
the device is not working properly code 31 windows 8 marvell
,
the marvell avastar wireless composite device adapter
,
windows 8.1 update from 8.0 wifi not working