WiFi issues on new Surface 2

Discussion in 'Microsoft Surface 2' started by Syd77, Oct 1, 2014.

  1. Syd77

    Syd77 New Member

    Joined:
    Oct 1, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    First of all, hi to all and thanks for all the knowledge shared in this forum.

    I am a new Surface 2 user and my first disappointment was that my unit had the battery not detected issue. Gladly, I went back to the store and got a second one with a functional batery. Now I am struggling with IE, Store and applications that requiere an internet connection.

    I have had the surface 2 for 2 weeks now and I have downloaded tons of updates since day 1 and they dont seem to end, however...after a while browsing the web or the store i lost connectivity. I dont lose Wifi signal or get disconnected from my wireless modem (have used it only at home for the moment) but I cant keep opening web pages as a "page not found" message appears and it does no longer work on any webpage with the problem solver at windows saying that I have no internet connection. I have downloaded a third party browser thinking that the problem was with IE (both classic and modern just stops opening pages) but I had the same issue.

    I have checked all my settings, I even have the security settings at medium and I have 2 more tablets (both on android) and one Ipod touch and all work perfectly with no interruptions. This happens at aprox, 20 minutes after I start browsing or using the store and if I reboot everything works fine again for that amount time and then I lose internet connectivity again. I do not lose my connection to the modem at any time.

    Does anybody have experienced a similar issue?

    Apologies for the long post and forgive any mispelling or incorrect grammar but English is not my first language.

    Thanks in advance to all and have a very good day/afternoon/night
     
  2. AdamTh

    AdamTh New Member

    Joined:
    Oct 29, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi, I'm having similar issues with the Surface 2 tablet, battery life leaves much to be desired and i'm having trouble connecting to Wifi, it won't connect at all!! I am using a Netgear WNAP210 router and have been in touch with Netgear, the only thing they suggested was to alter the router name to remove any underscores. I logged in as admin last night and changed it but still get the same frustrating message on the WIFI settings on the Tablet...it shows the router, I enter the password and then it thinks about it for a few seconds and then says "Unable to connect to this network" Can anyone please advise what to do? I was so annoyed last night I nearly ended up launching both items out of my window! Please help! Aaarrrrgggghhhhh!

    Thanks,
    Adam.
     
  3. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Welcome to you both

    What I don't see in either of your posts is that you tried a public hotspot or a friend's WiFi to see if you have the same issue. I suspect a configuration, (Or confusion), in the router is at fault but it needs to be isolated to your router.

    My first suggestion, if you haven't done it, is to power the router off for 30 seconds. Plug it back in and wait another minute before trying to reconnect.
     
  4. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,331
    Likes Received:
    1,279
    Trophy Points:
    113

Share This Page

Search tags for this page
microsoft surface 2 wifi issues
,
no wifi surface 2
,
poor wifi surface 2
,
poor wireless performance surface 2
,
surface 2 wifi disconnected
,
surface 2 wifi fix
,

surface 2 wifi issues

,
surface 2 wifi problems
,
wifi issue for surface 2
,
windows surface 2 tablet wifi issue