windows 10 on surface 3

Discussion in 'Surface 3 (Atom)' started by mtalinm, Jun 5, 2015.

Thread Status:
Not open for further replies.
  1. mtalinm

    mtalinm Active Member

    Joined:
    Feb 14, 2013
    Messages:
    602
    Likes Received:
    85
    Trophy Points:
    28
    I don't see a thread about this yet, so here goes.

    I installed build 10074 (latest on slow ring). Could not get the fast-ring build to install (10130 failed to install, twice).

    Short version is that it's quite a mess. Whereas 8.1 was zippy on the Atom processor, I find 10 to be slow - especially on web browsing but also more generally. Also, the picture-password sign in doesn't work most of the time; often the picture is not even shown.

    The worst part is OneDrive, which is throwing all sorts of sync errors I've never seen on my SP3 running 8.1. (And then there is the annoying "feature" that online-only folders no longer display thumbnails...)

    I might try it for one more day, but I'm pretty sure I'll revert. If they are planning to GA less than 2 months from now I can't imagine the 7/29 release is going to be much better for S3.

    Anyone's mileage vary?
     
  2. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,700
    Likes Received:
    422
    Trophy Points:
    83
  3. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Since it is being covered in the other thread, this one is closed.
     
Thread Status:
Not open for further replies.

Share This Page

Search tags for this page

windows 10 build 10130 install surface 3 pro fail

,

windows ten on surface 3