Windows 10 palm rejection issue

Discussion in 'Microsoft Surface Pro 2' started by ToluAbisola, Jul 31, 2015.

  1. ToluAbisola

    ToluAbisola New Member

    Joined:
    May 29, 2013
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    1
    Hi

    Yesterday I updated my Surface Pro 2 that was running Windows 8.1 to Windows 10 and was in a very happy place until I loaded up Zbrush and started to model something.

    It turns out that palm rejection isn't working in Windows 10 and even worse the latest Wacom feel drivers (731-7) will completely deactivate the pen, however reinstalling driver 712-9 will re-enable the pen.

    Has anyone else experienced this?
     
    Last edited: Jul 31, 2015
    AlienEric likes this.
  2. AlienEric

    AlienEric New Member

    Joined:
    Aug 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro
    Yes I've had the same issue with a Surface Pro 1 as well as other problems with Manga Studio Ex 5 and some programs seemingly requiring administrator privileges, even though my account is an administrator account. I'm rolling back to 8.1 for the time being. The other problems I can live with but palm rejection not working really damages my workflow.
     
  3. benjitek

    benjitek Active Member

    Joined:
    Jan 7, 2014
    Messages:
    622
    Likes Received:
    70
    Trophy Points:
    28
    My Device:
    SPro2
    I don't think Microsoft has issued SP2 specific graphics drivers yet. I noticed that post-Windows 1o I now have the generic Intel(R) HD Graphics Family adapter driver, with Windows 8.x it was a different driver, usually not as current as the generic one. They've issued a collection of W10 drivers for the SP3, hopefully the ones for the SP2 are on a back burner somewhere ;-)
     
  4. AlienEric

    AlienEric New Member

    Joined:
    Aug 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro
    Thank you for the heads up. I hope Microsoft doesn't forget previous versions of the Surface Pro. I'm sure they won't. I'll wait on 8.1 until a SP 1 and 2 Firmware update fixes this.
     
  5. markwparrish

    markwparrish New Member

    Joined:
    Jun 7, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I had this same issue. Updated to Windows 10 and then fired up OneNote 2013. Saw that the palm rejection wasn't working and couldn't believe it got broken. I started looking at all the configuration options. Under Devices > Pen I saw there was the setting, "Choose which hand you write with" It was set to right hand. I don't remember Windows 8.1 having a handedness setting for the pen. I set it to Left Hand since I am left handed and the palm rejection started working again. If the people also having this problem are left handed then that could be your issue. If your right handed then I couldn't say what the problem is.
     
  6. AlienEric

    AlienEric New Member

    Joined:
    Aug 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro
    Thanks for your help but I am right handed so it isn't that. However, I tried it in left handed mode and it does seem that palm rejection starts to work. Unfortunately, it introduced a few more problems when I tried it. When I took the pen away from the screen my fingers couldn't interact with the taskbar or other touch elements. It seemed as though the system had frozen but when I brought the pen back to the screen it started working as normal. This behaviour continued until I reverted to right handed mode. I think the only thing to do is wait for the driver update.
     
  7. AlienEric

    AlienEric New Member

    Joined:
    Aug 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro
    Hi just to confirm after a clean install all my other Windows 10 issues went away except the palm rejection problem. However thanks to markwparrish switching from right handed writing to left handed seems to enable proper palm rejection. The only other change seems to be that menus pop up on the opposite side of the pen but I'm not too fussed about that. So thank you very much.
     
  8. AlienEric

    AlienEric New Member

    Joined:
    Aug 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro
    Scratch that. It seemed to be ok until I tried doing some serious work. I don't think the palm rejection is gone, just not as accurate.
     
  9. trickster5000

    trickster5000 New Member

    Joined:
    Aug 11, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    I had exactly the same issue, palm block wasn't working after upgrade on a SP2 and a Lenovo Helix, changed it to left-handed, (again I'm left-handed), and it worked fine. I had actually changed it to left-handed before reading your post, but hadn't bothered to check if it fixed the issue. As it turns out, it now works perfectly on both machines. Thanks!
     
  10. tehJUGZ

    tehJUGZ New Member

    Joined:
    Aug 12, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro2
    on my sp2...the rejection works but only on the part of the screen where your hands rest...if you set on the pen settings as right handed..it only rejects the right side of the screen where you hover the pen...vise versa...i havent had issues with accidental press as of the moment so i think its all good...its also easier to change tools on photoshop...i wont lift my pen away to select tools with my other hand...
     
  11. AlienEric

    AlienEric New Member

    Joined:
    Aug 1, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro
    I agree there seems to be some form of rejection going on but for me it is far more ineffective than it was before. With the new, always present taskbar, I'm always accidentally opening apps while drawing. I've tried hiding the apps on the taskbar as well as moving it to the left and top of the screen but I always end up with the calender launching or Cortana. I also have issues where I'll have my pen on the screen while drawing and the ink line will spike out to the edge of the screen where a touch has been registered. It certainly doesn't behave this way in 8.1. I've also noticed that the rejection isn't as consistent when the pen is hovering over the screen. Maybe its just me and my use case but I couldn't work with it. The pen behaves normally again back in 8.1 so it's not any kind of hardware issue.
     
  12. Rayzor

    Rayzor New Member

    Joined:
    Aug 25, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro2


    I too was getting that scary 'spiking-out' issue, & changing to the left-handed option (note: I'm right handed) appears to have settled it down - but I'm still getting phantom zoom-ins/outs, & move it all abouts (???)
    My art software of choice is 'Made-With-Mischief', & 90% of my SPII playtime is on that package, but Windows 10 has made it (& others) almost totally unusable.

    Does anyone who's posted here 'know for sure' that Microsoft are aware of this & working on a fix?
    (or is it a 'fingers-crossed' hope that they are?)
     

Share This Page

Search tags for this page
how to set up palm rejection in windows 10
,
palm detection windows 10
,
palm rejection in windows 10
,
palm rejection not working properly surface pro windows 10
,
palm rejection on windows 10 surface
,

palm rejection windows 10

,
palm rejection windows 10 onenote
,
surface pro 3 palm rejection not working
,

windows 10 palm rejection

,
windows 10 palm rejection not working