Windows 8 Apps don't work for one user, but work for others.

Discussion in 'Microsoft Surface Pro 3' started by crimson, Jul 27, 2014.

  1. crimson

    crimson New Member

    Joined:
    Jul 24, 2014
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    1
    I have checked everywhere online, and I haven't found a single explanation for this.

    I have 3 user accounts.

    1. Administrator
    2. initial user
    3. new user

    So the initial user is the one you are forced to create when first setting up Windows 8.1. It's a local user meaning that I set it up without signing into a MSA.

    In both the Administrator and the initial user, all the WinRT apps/tiles work. Like the weather will show up and everything.
    WITNESS:
    [​IMG]

    [​IMG]


    Whether I change the Initial User to Standard or Administrator, everything still works fine. Of course, the Administrator can't open WinRT apps which is standard and normal. And the initial user can't use apps without signing into MSA. But it all still works perfectly fine.




    The problem is with the new user. The new user is meant to be in Administrator mode because it's my main account. But whether I set it up as Standard or Administrator, it's the same thing. None of my WinRT apps work.
    WITNESS:
    [​IMG]

    Even when I sign into my MSA with the new user, it's still the same thing. It synchronizes to my OneDrive online. It recognizes that I'm completely signed in online. Yet it's still the exact same thing with the WinRT apps. None of them work. Even when I try to open up the Windows Store. It just continues to try to open, but doesn't go all the way through. So whether I'm signed into my MSA for the third user or not, it still gives the same problem.

    I ran Windows Update, and it worked perfectly. Everything is up to date.
     
    Last edited: Jul 27, 2014
  2. crimson

    crimson New Member

    Joined:
    Jul 24, 2014
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    1
    SOLVED:
    A. Don't ever listen to Microsoft. They don't know what they're talking about. I was able to solve it with a little bit of troubleshooting with peers.

    B. To avoid this problem: do not disable Windows Firewall in Services. Even if 3rd party firewall is installed. Windows Firewall being disabled in Services is what causes this whole problem of WinRT apps not functioning in newly created User Accounts.


    C. If you're having this problem: it probably means that Windows Firewall is disabled in Services. Log into the built-in Administrator account, and set Windows Firewall Service to Automatic.

    STEPS:
    Open Control Panel.
    Open Administrative Tools
    Open Services.
    Right-click Windows Firewall service.
    Open Properties.
    Set the "Startup type" drop-down to Automatic.
    Restart computer.
    Windows Firewall Service will run.
    This will make WinRT apps begin to work again.
    (You can still turn Windows Firewall completely off in Control Panel. )


    NOTE: It may be necessary to wait a few minutes while logged into the user account so everything can update properly for all the apps to start working. Restarting the system again might be necessary. (The user account can be local, and need not be signed into any MSA.)



    WITNESS:


    [​IMG]

    [​IMG]
     
    Last edited: Jul 27, 2014

Share This Page

Search tags for this page

microsoft surface apps dont work