YouTube Video will Not Play on Surface Pro

Discussion in 'Microsoft Surface Pro' started by buffie, Jun 6, 2013.

  1. buffie

    buffie New Member

    Joined:
    Apr 16, 2013
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    I searched for help on this problem but did not find any help. I tried today for the first time to play a YouTube Video and it would not play with no errors indicated?? Is there something I should do? Matter of fact the video was one from this forum. Any directions or advice would be appreciated.
    TIA.:eek:mg:
     
  2. malberttoo

    malberttoo Super Moderator Staff Member

    Joined:
    Feb 26, 2013
    Messages:
    2,255
    Likes Received:
    428
    Trophy Points:
    83
    Location:
    Alaska
    My Device:
    SPro3
    What browser are you using? And what happens when you click on the link- nothing? Or, it goes to the page and buffers forever? A little more detail... : )
     
  3. buffie

    buffie New Member

    Joined:
    Apr 16, 2013
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    I use IE10 and it does go to the page and buffers forever.
    I get something that says learn more that says set the quality lower was running at 360. It says I should install latest version of Flash. I go to their page and it tells me my version is the latest.

    Need more info let me know.

    Sent from the SurfaceForums.net app for Windows 8
     

Share This Page

Search tags for this page
can't play youtube videos on surface pro
,

surface 3 not playing video

,
surface 3 wont play video
,
surface pro 3 not playing videos
,
surface pro issue playing youtube videos
,
surface pro not loading youtube videos
,
surface wou't play youtube video
,
youtube not playing on surface 3
,
youtube videos will notq play on surface pro
,
youtube wont play on surface