What's new

Disable password login on type-cover wakeup?


New Member
I just updated to W10 and now every time I open up my type-cover I'm required to log in (to my microsoft account? surface pro 3 account? I'm not sure which account it is honestly). I have the password requirement unchecked in netplwiz as well as not requiring a password on wakeup in the battery options. What am I missing?



Search for power options -> change plan settings -> change advanced power settings

At the top there are options for requiring password on wake up. Are those switched to off?


New Member
Yeah, there were only two that I could find, after waking up from sleep and turning on from power off, both were set to no.

I just tried toggling the netplwiz and battery options password settings (after not having touched them since before I upgraded from W8.1). No luck, no change. I switched my account type a local account and than back to a Microsoft account, no change (although I didn't check if it worked when only signed in as a local account).

At least when reverting back to a microsoft account, it had me set up a pin. So not at least it's a 4 digit pin and not my 16 digit password every time. I'll probably end up resetting W10 soon anyway and starting from scratch.
This is a common problem affecting everyone. Doesn't matter what your login settings are, they ask for your password. My login setting is to ask for my PW after 15 minutes but they have asked for it after I was gone for less than 1. Its one of many issues of Windows 10 that I hope will be fixed soon.


Active Member
This seems to disable both when waking out of sleep or hibernate, that is it turns on right to the desktop.
The problem this fixed for me is even though I checked to disable requiring a password when it wakes up...

it still woke up to the logon screen.
Now it wakes directly to what I was doing on the desktop.

Edit: It does also disable the lock screen when you boot, so it opens directly on the logon screen (just tested this). But it did fix not having to re-enter my password every time it came out of sleep.
Last edited: