What's new

Latest Firmware - Battery Weirdness!

sockfish

New Member
Count me in for battery weirdness as well along with closing the lid problems. Battery is at 10% and won't charge above that (shows plugged in but not charging). Strangely, the battery doesnt seem to be going below 10% either and shows no remaining battery estimate.
 

jnjroach

Administrator
Staff member
Count me in for battery weirdness as well along with closing the lid problems. Battery is at 10% and won't charge above that (shows plugged in but not charging). Strangely, the battery doesnt seem to be going below 10% either and shows no remaining battery estimate.

Hold the Power Rocker Up for 15 seconds as you power the unit up from a cold boot, this brings you to UEFI Boot Screen, exit and save and it should reset the battery.
 

AZsurface

New Member
Purchased Surface Pro 2 on Dec. 2nd. Having major issue with battery not charging. Tried unplugging, moving to different plugin, restarting. Shows Surface is plugged in, but says it's not charging. Followed all the online guides for correcting the problem with no fix.
If I unplug charger from wall outlet computer goes dead. Everything was fine until today.
 
OP
M

MrTPN

New Member
Thanks all for the feedback!

Glad to see that this was not just me or something i was doing resulting in issues.

It is also frustrating that with a device of this calibre and marketing materials that its not more "Seamless" i have to say its times like this that i miss my old Apple MacBook Pro. Appreciate that Apple have had its fair share of issues (....cough, Maps) but basic functionality like battery, screen, keyboard, etc. always worked flawlessly!

MrTPN
 

lestat200

New Member
the same for me, I have sent my surface pro 2 back to MS and them sent me a new one. before I tried to reinstall windows but nothing changed
 

iliketoys

Member
I also have the issue of my SP2 not going into sleep mode properly and waking with little battery power left sitting overnight.

Secondly, the other day the battery was saying "9% battery left" and didnt increase when plugged in. I saw a fix on another forum that seems to have worked for me.

Unplug and power down, let it sit for 20 min or so, then plug back in (still powered down). Let charge for 20 min or so, then unplug it and power it back up.
 
I also have the issue of my SP2 not going into sleep mode properly and waking with little battery power left sitting overnight.

Secondly, the other day the battery was saying "9% battery left" and didnt increase when plugged in. I saw a fix on another forum that seems to have worked for me.

Unplug and power down, let it sit for 20 min or so, then plug back in (still powered down). Let charge for 20 min or so, then unplug it and power it back up.

If the battery indicator is not going up when plugged in try shutting down then holding volume up while holding power for 15 seconds. The surface logo will flash a few times then it will stop. Press power and boot normally. This procedure actually crashes the UEFI and causes it to reset which apparently fixes this issue. It will happen again but hopefully the firmware fix comes soon.
 

Members online

No members online now.
Top