What's new

Post Your SP3 Power/Battery/Charging Issues Here

scottysize

Member
Yes, battery life is surprisingly poor, even after the firmware update. I got about the same - 4 1/2 hours with about 40% brightness.
4 hours on 50% screen brightness playing a stupid golf game. It's a basic game, not graphic intense. I'm kinda disappointed as well. I thought I'd at least get 7-8 hours out of it with the screen on. Now, 4 hours is still better than my MacBook Pro which would have lasted about 3 hours with the screen on continually, but I thought this was suppose to get better battery life than 4 hours with the screen on.
 
OP
leeshor

leeshor

Well-Known Member
For all the people concerned about the battery life there are hundreds of variables and many are adjustable. Look through the posts on power management in this thread for starters, but also consider that using WiFi, (type of router - security - signal strength all have an effect on battery use), screen brightness obviously, blue tooth use, mail sync frequency, background processes, types of AV software and update frequency and more. Not all people will be able to get 7 hours of actual use, if that's what they want/need without doing some research and making adjustments.

If you don't do the work, you aren't likely to get the battery life you want and no 2 people are going to have the same configuration and as a result, the same battery life. These issues are not limited to the Surface by any stretch. They apply to any tablet or laptop.
 

riggi

Member
Are you guys with poor battery using the pen a lot?

I'm not sure if the n-trig is similar to the wacom pen, but I know on the SP1, using the pen drains the battery a lot faster than using my bluetooth mouse or finger.
 

EMINENT

Active Member
Last night, I got 7 hrs. on battery with 10% left with 30% auto brightness, Bluetooth on, browsing, emails, remote desktop for 20 mins., used the pen for 20 mins., installing Office and Photoshop, and casting videos for an hour or so to my Xbox One.
Pretty happy so far!
 
Last edited:
OP
leeshor

leeshor

Well-Known Member
Last night, I got 7 hrs. on battery with 10% left with 30% auto brightness, Bluetooth on, browsing, emails, remote desktop for 20 mins., used the pen for 20 mins., installing Office and Photoshop, and casting videos for an hour or so to my Xbox One.
Pretty happy so far!
Sounds pretty good to me.
 

Bandito

Active Member
Yesterday, I got 6 hours of use out of my SP3 with about 40% battery remaining, according to the battery report. I then charged it back up to prepare it for use at work today. I'm running the screen at 40% and was doing software installs for most of that time with some network troubleshooting and web browsing, too.

One thing that I am having trouble with is power management. I created my own power management scheme, but it seems to not be working. For example, I have the display set to turn off after 10 minutes of inactivity, but it doesn't do this. It dims down to 30% after 10 minutes, but remains on. It should sleep after 15 minutes, but, as I said, remains on with the screen dimmed. I just went through and changed the settings a bit and re-saved everything to see if that will make any difference, but will just have to keep an eye on it for a while to see what it does now.

Has anyone else tried creating their own power management scheme? If so, did it work for you?

Thanks for any info that you can contribute!
 

cdegallo

New Member
Power plan settings for sleep computer and turn off display override one another

EDIT--apparently the "put computer to sleep" and "turn off display" settings in power profile, for some reason, are automatically set equal to one another, and can't be set independently. Doesn't anyone know why?

I've noticed that the power plan settings for "put the computer to sleep after" and "turn off display" negate the other's settings. Anyone else seen this? For example, if I set the computer to never sleep when plugged in, but then change the default "turn off display" from 'never' to '10 minutes', it ends up resetting the "put computer to sleep after" time to 10 minutes (the default).

Super frustrating, as I have my SP3 as my desktop replacement, managing NAS-to-external drive backups. Right now, if I want to leave it running for hours at a time to complete a backup, it also means having the display on unnecessarily.

Tried creating a custom power profile, the same thing happens. Anyone know what's going on with this?
 
Last edited:

puma

Member
I have had several BSODs . Today I noticed that when it was on a table in standby .. it suddenly came on. I went into the event logs and saw that is had restarted from a Bug Check. I filtered the system event log for critical and saw it has restarted 11 times in 3 days. I scan the dmp file and it lists ntosknrl.exe. Unexpected shutdown .... I am wondering if maybe it is the wireless issue, or what. No idea. Just before I went to wake it up.. and I had to press and hold power to reboot it. I am hoping future update will fix this.
 

ctitanic

Well-Known Member
I'm getting 6.5 hours just browsing, answering emails and around to mins. of streaming video. I use a lot the Pen. In fact, that's all I use.
 

jnjroach

Administrator
Staff member
I have had several BSODs . Today I noticed that when it was on a table in standby .. it suddenly came on. I went into the event logs and saw that is had restarted from a Bug Check. I filtered the system event log for critical and saw it has restarted 11 times in 3 days. I scan the dmp file and it lists ntosknrl.exe. Unexpected shutdown .... I am wondering if maybe it is the wireless issue, or what. No idea. Just before I went to wake it up.. and I had to press and hold power to reboot it. I am hoping future update will fix this.
Per chance did Metered Connections get selected on your WLAN? There are reports that metered connections can cause this....

Another option is to delete your existing connections and add them back.
 

jnjroach

Administrator
Staff member
I'm getting 6.5 hours just browsing, answering emails and around to mins. of streaming video. I use a lot the Pen. In fact, that's all I use.
Are you still using the original WiFi Driver? I've noticed I'm losing battery life using it....
 

ctitanic

Well-Known Member
Are you still using the original WiFi Driver? I've noticed I'm losing battery life using it....
No, I'm using the latest update. I have a dual band router so If I don't use the 5G band I'm good. AC seems to me still a very green technology I'll wait until Christmas when it's more stable..
 
Last edited:
Search tags for this page
microsoft sp4 lader

microsoft surface battery and charger issues fa

no battery issue sp3

sp3 battery download
sp3 battery drain after install windows 10
sp3 drains faster than charging when playing games
sp3 firmware update charging

sp3 not charging

surface pro 3 75 percent not charging

tabletmark sp3

Top