What's new

Post Your SP3 WiFi/Internet Issues Here

Problem here: 5GHz, speed tops >90Mbps initially but falls to ~30Mbps subsequently. It regains >90Mbps if the network is re-connected.

On the Android phone, it's consistently ~90Mbps.
 

murali

New Member
brought a sp1 initially.....everything was fine except it came with a dead battery outta box......so replaced it with sp3 in September 14....now I have wifi issues.........wifi and Bluetooth completely disappeared. I cud locate their drivers in hidden mode in device manager. I have uninstalled marvell avastar wifi n/w adaptor driver manually, scanned for hardware changes but no use. again downloaded October firmware updates and tried installing manually....no use...... tried trouble shootinh the network adaptor from control panel.....it is identifying the problem but fails to fix it......still goin on with a the so called laplet w/o wifi or Bluetooth...... even my 50dollar phone has a perfectly working Bluetooth. chose sp3 over apple mac and regretting badly.....any suggestions??
 

Maciek

New Member
The only issue I have with WiFi is that it won't connect back to wifi after being asleep. I turned InstantGo off now and it seems like the booting time is shorter than with InstantGo turned on...

I have skimmed thru this thread, but I couldn't see any concrete fix for this. I'm not sure what - if anything at all - can be done?

I haven't been getting any other issues with my Surface Pro 3 i7-512GB. I am not saying anything, but there could be hardware differences in those models, not significant, but apparently enough to cause all sort of various issues to various people.

My GF and I have jailbroken iPhone 5s, but her's is 16GB and mine is 64GB and you would thing they're identical, but they behave very differently in various scenarios... This "anomaly" applied to previous devices I owed in my life; hence I think we all will get different type of issues....
 

stonerwinst

New Member
I am starting to lose hope that Microsoft can fix the WIFI issues. The SP3 has been out several months and not even a hint or a word that a fix is coming.

I suspect the problem is in the hardware and not even a software patch can fix it.

Very disappointing since I am reminded of this problem everyday with the "Limited" connectivity. Very silly that I have to go toggle the WIFI switch everytime to fix it.
 

jnjroach

Administrator
Staff member
I am starting to lose hope that Microsoft can fix the WIFI issues. The SP3 has been out several months and not even a hint or a word that a fix is coming.

I suspect the problem is in the hardware and not even a software patch can fix it.

Very disappointing since I am reminded of this problem everyday with the "Limited" connectivity. Very silly that I have to go toggle the WIFI switch everytime to fix it.
There has been 4 updates already and I know of at least two additional updates that are scheduled (I would expect one tomorrow). I would estimate that 90% of the issues are corrected on the non-Hyper-V deployments and on those running Hyper-V I would say 80% of the issues are corrected.

If you look at last month's Firmware Update (the one on the 28th) you'll notice that the Intel PCIe bus driver was updated due to it going into a sleep state and it failed to return on wake....do a little digging that is the same bus the Marvell WLAN Adapter is on (moved from the USB Bus to the PCIe Bus because of 802.11AC requirements are beyond USB 3.0).
 

jnjroach

Administrator
Staff member
I didn't see any Surface specific updates today, last month they sent out the one (Pen) on Patch Tuesday and the next one out on the 28th, I still expect we'll see something this month....
 

RickH

New Member
Ok, I'm not sure if this belongs here, since this thread seems more directed at wifi problems that have been persistent from right out of the box. Nevertheless, the sticky says "Post all your wifi issues here", so here I go.

I think my wireless controller just died!

I came home from work today and woke my Surface Pro 3 (i7, 256gig). Hmm, no internet, that's strange. I have had absolutely zero wifi issues out of this machine since day one. I fired it up the first time, it found my network, I entered my wifi password, and it's been absolutely golden ever since. I've only had it about a month, so I think Microsoft had all of the early problems ironed out by the time I got mine. I clicked on the network symbol in the task bar, and out pops the Networks bar stating "No networks found." I toggle the wifi off, then on again - no change. Then airplane mode on and off. No change.

I decide to reboot the machine, no big deal. When I went to the power options menu to restart I notice it says "Install updates and restart" or something to that effect. I figured maybe the problem was an uncompleted driver install (I have it set to download and install updates automatically - I am rethinking that plan now). Windows shuts down, showing the "Installing updates, do not turn off your computer" etc screen, I don't touch anything, after a minute it shuts down and restarts. When the log in screen comes up, I still have the wireless strength meter showing no signal with a little red circle with an "X" in the middle. I log in, same as before "No networks found". !@#@% !@^#&! ^$$ What the heck is wrong with this thing?

So I power cycle both my router and cable modem. Still "No networks found". I pull out my phone, iPad, and ancient Toshiba laptop. Not only can all of them see both bands on my router, they can each see several of my neighbor's routers as well. Surface sees not one single network available.

So, now I convince myself it had to be the result of the update Windows just installed. I come here to see if others are having issues and find nothing from today. Nevertheless, I go to Recovery and see I have a recovery point from 11/15. I roll back to 11/15 and still nothing. Still no wireless networks found. I went to the "Programs and Features:Installed Updates" folder and confirmed there are no updates showing beyond 11/13 (and the wireless controller was working fine last night).
  • I go to the device manager and disable and re-enable the Marvell controller - Nothing
  • I uninstall the controller but leave the software and reboot, Windows automatically reinstalls it - Nothing
  • I go to Surface Support and download the driver pack (on my laptop, before anyone asks), and uninstall the controller and delete the driver. After reboot, it does not reinstall the controller because I deleted the driver, and I manually install it from the October driver pack (driver version 15.68.3059.117) - Nothing
  • Throughout all of this, the Marvell controller reports that it is installed and working properly.
  • My SSID is not hidden, and evidently neither are my neighbor's. Three other devices can see 4 or 5 available networks sitting right next to the Surface which reports "No networks found".
  • 24 hours ago, the Surface was functioning flawlessly.
Can anyone think of anything I have missed? I think my wireless controller just croaked. I no longer think the update had anything to do with it, pure coincidence that it happened to be waiting to complete installation when my wifi controller went belly up. I am prepared to attempt a complete Windows restore, back to "Out of the box" status. I wanted to see if any of the Gurus here had any other suggestions first.

Sorry about the wall of text! I wanted to answer every question I could anticipate up front to save a little back and forth. I really want to love this machine, but it's getting harder at the moment.

Rick
 

ronnyb29

New Member
the wifi issue is better since the update yesterday, i've still had to reboot about 40% of the times my SP3 goes to sleep. This is a POS, save yourself the hassle...
 
Search tags for this page
sp3 wifi drivers 10074

sp3 wifi issues

sp3 wifi issues youtube
surface pro 3 wifi connects at lower spee when switching networks
surface pro 5g connection issues
surface pro exclamation on wifi
surface wifi problem after windows update feb 2015

wifi issues sp4

wifi slower on surface pro 3 than other devices

windows 10 wifi issues sp3

Members online

No members online now.
Top