What's new

Post Your SP3 WiFi/Internet Issues Here

Ruudfood

New Member
I'm a little late to this thread but I've also had problems and the workaround is to turn wifi on and off and leave it for 10 minutes to "correct" itself.
 

Mach.85

New Member
Surface Pro 3
i5-4300,RAM 8GB.
Windows 10/64 Ver:1511

After receiving an automatic update I noticed my wifi connection was gone.
No problem, I'll just go to Device Manager and see whats going on, maybe roll back the driver.
Lo and behold, My wifi adapter was missing. (Yes I chose view hidden devices).
There was no reference at all to Marvel in Device manager or anywhere else for that matter.
The only reference to Marvel was in the registry (I'm not that confident to be doing registry hacks).

There was no restore point to go to.
My image would not load. So...after exhausting all resources I was forced to do a clean 10 re-install.
I then went about the painstaking process of reinstalling and setting up all of my programs.
The wifi adapter was back and working fine.

But being as slow on the uptake as I am, I did not set Windows NOT to update automatically.
So, the updates pushed again, and the same thing happened, again... No Marvel Adapter to be found.

I performed yet another clean install. Re-install and setup of programs.
Marvel is back and working fine.

I have since stopped all updates while I try to figure out whats going on.

I will humbly accept any advise.

Thanks!
 

BobcatALR

New Member
Count me as a late add as well. Netgear AC1900 c7000 and SP3 i7 512GB. Worked flawlessly up until my return home from a 3 year assignment in Toronto, ON, CA. Purchased the C7000 over a year ago, and the family has been using it. Upon return home, I find the SP3 connect, disconnects, and does all kinds of weirdness. Netgear seems to be pointing its fingers as MS, and MS isn't really saying anything. I tried every software trick I know, and finally wiped the the thing and did a fresh install to see if some of the network hacks I had done in Toronto to make it work on our corporate network were to blame - all to no avail. Currently have it installing some updates from November. Let's see if this fixes it...

(I note a ton of threads stating that then Netgear AC products aren't playing well with SP3/Marvel. Can anyone comment of the Linksys equivalent to the C7000? I've used Linksys for decades without issues, and this is my first foray into Netgear wifi equipment. So far: wholly unimpressed.)
 

DForbes1967

New Member
Woke up this morning and within 5 minutes of being online with my SP3 it locks up. No biggie, done this several times before. Pull it off the dock and force power restart and bam NO BT or WIFI anymore!!! Spent the better part of a Sunday trying to figure out why. Marvel driver is present and cannot roll back as it grayed out. Tried uninstall Marvel and reboot, approx 20X, yeah no kidding. Wifi shows up in the task bar and states its on but shows no networks even though 2 other computers have no problem. Any hints or am I screwed like everyone else here?

Thanks,

Dennis
 

stevo

New Member
Hi,
I have win 10. I cannot connect to the wifi of my university because win doesnt let me enter my login data. When i try to enter my username or password, the entering field gets cleared. this is very odd, plz help!
 
Search tags for this page
sp3 wifi drivers 10074

sp3 wifi issues

sp3 wifi issues youtube
surface pro 3 wifi connects at lower spee when switching networks
surface pro 5g connection issues
surface pro exclamation on wifi
surface wifi problem after windows update feb 2015

wifi issues sp4

wifi slower on surface pro 3 than other devices

windows 10 wifi issues sp3

Members online

No members online now.
Top