What's new

Stuck Shift, Ctrl and Alt Keys - Type Cover Keyboard

jrapdx

Member
I'm experiencing the same problem with my weekold system.
Has anyone been in contact with M$ about this, are they looking into this?

Seeing that you're new to this community--and it is a very informative place--it's just one of those several annoying, vexing little problems frequently mentioned, and should I say mentioned repeatedly? But that is decidedly the case. My sense is that many are convinced MS is not too worked up over these complaints. After numerous purported "fixes", some notice possible improvement (or never noticed problems), others see no difference at all--just as bad as ever, and a good-sized fraction (1/4?) have more of a problem than before the update.

The general advise is do not apply updates automatically, but accept notification updates are available, and install updates once shown to be worthwhile or at least not harmful. This is especially true for firmware updates. Anyway, after significant updates are issued, usually reports start filtering in after a few days to a week.

Personally, I prefer to lag behind for a while before installing major changes to the system. I've learned the hard way, "upgrade" is the most fearsome word in computerdom.
 

Philtastic

Active Member
So with the Diablo 3 expansion out, I've been playing it more on my SP2 and finding that the shift key really likes to stick again. I don't think it's as bad as it used to be but, every once in awhile, it'll stick. Anybody else still having a problem with this?
 

gabriel

New Member
I have the exact same issue on the sp2 with tc2. It happens in all programs way too often but a perfect fix for it I have found is pressing ctrl+alt, not sure why it works or how I came across it but tried it randomly one time and it somehow just goes back to normal.
 

mbaker911

New Member
I too have this exact problem with the type cover 2. I don't know if it a mechanical or software problem. If I disconnect then reconnect the keyboard it seems to resolve it, so I suspect it is a software problem. Has anyone with this problem tried switching to a type cover original or a touch cover to see if the problem persists?

This is one extremely annoying problem to hav. I considered trading in my type cover 2, but I don't want to do that if it is a software issue.

Microsoft, are you listening?
 

dgg4

New Member
I'm glad I found this thread so I know it's not just me...thought I was going crazy, or snake bit, or something.

I've had this problem for quite a while with my SP2 and type cover 2. Happens whether I'm using the MS bluetooth arc mouse or not. Rebooting doesn't stop it from happening. Occurs randomly enough I can't figure out what's causing it. But it SURE IS ANNOYING!

Thx for letting me vent.
 

dirtyvu

New Member
The better fix is:

1) make sure the surface keyboard is attached to the computer
2) to go to Device Manager > Human Interface Devices
3) for every "USB Input Device", go to Properties. then go to the Power Management tab and uncheck the "Allow computer to turn off this device..." option

9enPR2I.jpg
 

Staff online

Members online

Top