Metro unresponsive upon after booting SP3 up

Discussion in 'Microsoft Surface Pro 3' started by MilesTeg, Sep 23, 2014.

  1. MilesTeg

    MilesTeg New Member

    Joined:
    Aug 3, 2014
    Messages:
    21
    Likes Received:
    4
    Trophy Points:
    3
    I'm running with the i7 SP3 and on occasion the metro UI will be completely frozen and unresponsive to either my finger and keyboard/touchpad input. I can still move the mouse arrow around on metro but I can't launch any apps or scroll the UI about to other parts of the screen. I don't think it's heat related as has happened inside with cool room temperature.

    The only option that works is to shutdown --- restart and hope the next boot into metro gives me a workable metro UI. I don't know what causes this as I can't replicate the problem - it seems to happen at random.
     
  2. ctitanic

    ctitanic Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    2,194
    Likes Received:
    577
    Trophy Points:
    113
    Location:
    Hollywood, FL
    My Device:
    SPro3
    Usually those are the signs of a corrupted driver or hardware issue. My recommendation would be to do a refresh. If the issue persist then it's a faulty hardware and you should exchange the unit.
     
  3. GTiceman

    GTiceman Active Member

    Joined:
    Aug 4, 2014
    Messages:
    561
    Likes Received:
    67
    Trophy Points:
    28
    My Device:
    SPro3
    I have noticed some unresponsiveness recently when trying to launch metro apps. However my finger input is still registered as is the select of the app.
     

Share This Page

Search tags for this page

sp3 trackpad unresponsive in modern apps