My touchpad just got a lot better

Discussion in 'Microsoft Surface Pro 2' started by eee, Jul 6, 2014.

  1. eee

    eee Member

    Joined:
    Jan 2, 2014
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    I read about the 'Sticky Keys' problem with the Touch Cover and used the instructions on this page solve it:

    The fix:
    Open device manager - either type "device manager" from the start menu or right click on the start button and choose it from there.

    When DM opens, expand the Human Interface Devices tree - do this while you have your touch or type cover attached. In the tree you should see "Microsoft Input Configuration Device".

    Right-click on "Microsoft Input Configuration Device" and select Disable.

    Verify you've disabled the device by looking for the little down arrow that appears over the icon.

    At this time disconnect and reconnect your type or touch cover.

    Test to make sure you no longer have sticking keys.
    It seems as a side effect, typing itself has improved and the trackpad has too. The trackpad used to not register my touches a lot of the time, but now it has improved by 100% and is pretty decent now.

    I'm not sure if I'm hallucinating or not but I don't think so... give it a try.
     
  2. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    I experience no difference. And I lose drag lock feature when I double tap, and keep holding when doing the last tap.

    I find the touchpad work fine if you set the speed to 1 step before max, and have enhance pointer precision enabled.
     

Share This Page

Search tags for this page

disable microsoft input configuration device surface