Solved processor speed won't go above 1.2GHz

Discussion in 'Microsoft Surface Pro 3' started by JasperTheDog, Oct 2, 2014.

  1. JasperTheDog

    JasperTheDog New Member

    Joined:
    Oct 2, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi Guys,
    I'm probably missing something obvious, but I noticed today when using Lightroom that the processor speed in task manager never went above 1.20 GHz. So I downloaded XTU and did a CPU stress test and again the processor never went above 1.20 GHz.
    Is this normal? If not can anyone help. It's an i5 with 4gb ram.

    Cheers
    Colin
     
  2. Fast-T

    Fast-T Member

    Joined:
    Aug 12, 2014
    Messages:
    37
    Likes Received:
    6
    Trophy Points:
    8
    Are you running it on battery?
    My SP3 won't go above 1.2GHz on battery, but run full speed while plugged in.
     
  3. Chuck_IV

    Chuck_IV Member

    Joined:
    Sep 7, 2014
    Messages:
    82
    Likes Received:
    15
    Trophy Points:
    8
    I'm guessing this also has to do with the Balanced Power profile it uses. I suspect if you try the High Performance Power profile(only available after turning Hyper V on), it will go above 1.2ghz on battery.
     
  4. JasperTheDog

    JasperTheDog New Member

    Joined:
    Oct 2, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thanks guys, yes it was on battery power, just never noticed it before and thanks for the tip regarding Hyper V.
    cheers
     

Share This Page