screen problems with gaming

Discussion in 'Microsoft Surface Pro' started by tatwood, Feb 15, 2013.

  1. tatwood

    tatwood New Member

    Joined:
    Feb 1, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I know that a lot of people are having problems when they go into a game the screen is not the right size. I bought a couple of games off steam today and I can not get the whole picture to show only about a quarter of the top left screen is showing. I have tried adjusting from 800x600 to 1920X1080 and everything in between but does not fix the problem. anyone have a fix for this?
    Thanks
     
  2. Ashles

    Ashles New Member

    Joined:
    Jan 14, 2013
    Messages:
    59
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Brighton, UK
    I am having the same problem with Baldurs gate 2 - most irritating is that it was working fine, then changed, so I think it should be a simple fix in theory. The compatibility troubleshooter is not fixing it.
     
  3. Nemesis296

    Nemesis296 New Member

    Joined:
    Feb 8, 2013
    Messages:
    57
    Likes Received:
    1
    Trophy Points:
    0
    What has worked for me is to use the compatibility troubleshooter on the EXE which is launched. If you say that you have problems displaying it properly (don't use the recommended troubleshooter), and then that the large-scale fonts are causing the problem, that usually solves it for me. There's another thread floating around here which has more information about gaming on the Pro.
     
  4. marcux

    marcux Member

    Joined:
    Feb 7, 2013
    Messages:
    40
    Likes Received:
    9
    Trophy Points:
    8
    Ok, i had this problem and fixed it, press f7, the monitor switch and change the display mode to show same screen on both monitors,... now it will appear to fill up the screen, your welcome :)
     
  5. marcux

    marcux Member

    Joined:
    Feb 7, 2013
    Messages:
    40
    Likes Received:
    9
    Trophy Points:
    8
    Got this from another forum post,

    downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22375&lang=eng

    This is the latest driver for the HD 4000. Looks like it just hasn't been pushed out via Windows Update for some reason. I haven't seen any issues using it, but it does enable the advanced graphics settings. It looked like the scaling was done appropriately with this driver after install automatically. If you change the resolution and it doesn't scale full-screen, do the following:

    1) right click on desktop 2) Go to "graphics properties" 3) Under Display->General Settings you can change the option under Scaling (this is also can be done by pressing <Ctrl><Alt>F11 **remember to press Fn and F11 on a type/touch cover to actually press F11)"
     
    1 person likes this.
  6. tatwood

    tatwood New Member

    Joined:
    Feb 1, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    downloaded the driver and got into where the scaling is and there is nothing to change it to... I'm lost of this whole problem
     
  7. docjoe

    docjoe New Member

    Joined:
    Feb 15, 2013
    Messages:
    5
    Likes Received:
    3
    Trophy Points:
    0
    Location:
    Minneapolis
    My Device:
    SPro3
    I am having the same problem, not with every game but many of them. Tried the F7 but that didn't work. Also tried compatability mode. Hopefully we'll have a fix for this soon! I am amazed at what I am able to run though. Even Borderlands 2 runs well with good graphics.
     
  8. skido700

    skido700 New Member

    Joined:
    Feb 19, 2013
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    0
    W2 starts in a TINY screen. It's like 2 inches by 2 inches! I installed and played warcraft 2 when I first got my surface and it worked great, but now there is nothing I can do about it! I've tried messing with the DPI settings, compatibility troubleshooter...

    Any ideas? When I take a screenshot it looks like it's full screen! So obviously the game, or Windows, completely disables the surrounding 90% of the screen.
     
  9. Javi

    Javi New Member

    Joined:
    Feb 19, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Having same issues here. Sometimes ive managed to work around it by setting display mode to ''extend'', changing to 1366x768, and running game at 1366x768 after desktop is set to 1366x768 with extend to 2nd display. But it doesnt work with all games and its a hassle to make it work before launching each game. Im going to push the new intel hd4000 driver and/or use 'duplicate'' mode to see if that fixes it and post results.
     
  10. skido700

    skido700 New Member

    Joined:
    Feb 19, 2013
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    0
    Fixed! Marcux's fix on Post #5 fixed the issue for me. After installing the Intel drivers, I had to change the resolution to the 1366x768 in the Graphic Drivers settings, then it worked.
     

Share This Page

Search tags for this page
games not scaling properly on surface pro 2
,
surface book game scaling
,
surface pro 2 gaming issues
,
surface pro 800x600
,

surface pro full screen scaling

,
surface pro fullscreen steam
,

surface pro game resolution problems

,
surface pro game scaling
,
surface pro gaming problems
,
surface pro gaming resolution