Solved Marvel AVASTAR Bluetooth Radio Adapter Error

Discussion in 'Surface Pro 2017' started by Helene, Aug 1, 2018.

  1. Helene

    Helene New Member

    Joined:
    Dec 16, 2014
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    This is constantly going into error condition. I have tried to see what occurs immediately before. Event Manager always shows a series of DistributedCOM errors but I can't find out what these are/mean.
    Eventually the Marvel AVASTAR BT radio fails with Code (43) which tells me exactly nothing!
    The driver version for the above is 15.68.9120.47 which according to my searching is the most current one.
    Once the adapter fails the only resolution is to restart the computer.
    As suggested in another thread I have unchecked the power option to turn off the device to save power.

    I am on
    W10 and up to date on all releases.

    This problem is making my Arc Touch Mouse SE and my MSFT BT keyboard unusable.

    Does anyone have any ideas. MSFT Support has no suggestions.
     
  2. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,455
    Likes Received:
    1,125
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    My driver is 15.68.9114.29 and works fine. I am on a Windows Insider future release of Windows 10.

    Perhaps you should roll back your driver, as it may be conflicting with something else in your system.
     
  3. Helene

    Helene New Member

    Joined:
    Dec 16, 2014
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    Thanks. How to I roll back the driver? When I go into the driver properties.....Roll Back Driver is greyed out.
     
  4. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,455
    Likes Received:
    1,125
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    Hold on there. My driver is now 15.68.9120.47 after an Insider Windows Update today. Works fine.

    So I am thinking that some setting is wrong. Have you removed the device and then immediately performed a cold boot?
     
  5. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,455
    Likes Received:
    1,125
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    Hold on...

    My driver was updated to 15.68.9120.47 today, after an Insider's update. Works fine.

    Do this:
    1) Start Device Manager
    2) Uninstall the device, and its software
    3) Immediately reboot
    4) Start Device Manager
    5) System should ask you to install drivers. Choose to search online.
    6) Allow to install

    This may correct some setting which is wrong on your system.

    Let us know ...
     
  6. Helene

    Helene New Member

    Joined:
    Dec 16, 2014
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    I did so much troubleshooting I'm not sure if I did this but I removed the driver and performed a cold boot before I saw your last note. Driver version now at 15.68.9112.23 date 12/2/16. I didn't note the date on the original driver but I'm sure it was 2017! BTW, system auto installed the driver, did not ask.

    So I'll see if this does the trick. The problem is unpredictable - I can go all day without the issue - or 10 minutes. I'll let you know.

    Thanks for your help.
     
  7. Helene

    Helene New Member

    Joined:
    Dec 16, 2014
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    NUTS. I have auto update turned on.....The system just replaced the driver to the one that may be at the root of the problem.
     
  8. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,455
    Likes Received:
    1,125
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    Well let us know if it is fixed.

    When you uninstalled, other regulistry settings were also removed. Perhaps those settings were corrupted, and now you are okay.
     
  9. Helene

    Helene New Member

    Joined:
    Dec 16, 2014
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    FAILED! Finally trapped the events. The Marvel adapter failed to respond at 2:21:47 and was removed. The final ERROR was at 2:23:14 when it was unloaded.
     

    Attached Files:

  10. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,455
    Likes Received:
    1,125
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    Okay, @Helene, let's try to get you fixed up.

    Change your driver to be a Microsoft generic driver rather than one from Marvell.

    1) Start Device Manager
    2) Select your Marvell AVASTAR Bluetooth Radio Adapter
    3) Right-click, then choose Update Driver
    4) Choose the second option: Browse my computer for driver software
    5) Choose the "Generic Bluetooth Adapter", Next, then Close after it installs.

    And again, let us know if this fixes your troubles.

    By the way, the issue may be regarding compatibility with your router. The cause is not yours, however, but may be an oversight by Microsoft or Marvell engineers.

    marvellbluetooth.png
     
  11. Helene

    Helene New Member

    Joined:
    Dec 16, 2014
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    Network adapter AC Network Controller.png Network controller fatal error.png

    Done! Now to see if this worked.

    Found the attached errors on the network
     
  12. Helene

    Helene New Member

    Joined:
    Dec 16, 2014
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    It appears changing to the Generic BT driver did the trick. My BTH mouse has been up and running since I changed drivers. I have put my SP to sleep and performed cold start and restarts and ALL IS WELL.

    Can't thank you enough.
     

Share This Page

Search tags for this page
azs
,
best cameras
,

news