Solved USB-port keeps disconnecting

Discussion in 'Microsoft Surface Help' started by Eplak, Feb 1, 2016.

  1. Eplak

    Eplak Member

    Joined:
    Feb 1, 2016
    Messages:
    49
    Likes Received:
    7
    Trophy Points:
    8
    Location:
    Norway
    My Device:
    SPro4
    Hi!

    I have already gotten a new SP4 off warranty, and I have been experiencing that my USB-port keeps disconnecting and reconnecting infinitely when charging my phone. Is this a hardware failure or has it something to do with recent updates?
     
  2. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Welcome to the forum

    New - SP4 - off warranty? How did that happen?

    Are you using the port on the Surface or the one on the power brick?

    Some devices seem to be drawing more power than the USB port on the Surface can output. I would try a flash drive to see if you have the same issue. You may need a powered HUB though it would seem a phone should not pull that much power. Try a USB flash drive to see if you have the same problem
     
  3. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,698
    Likes Received:
    422
    Trophy Points:
    83
    I think he means that this is a replacement SP4 he got through making a warranty claim.

    OP: what phone are you using. Some phones have the ability to "slow charge", others do not and demand the full draw, something the SP4 may not be able to provide.
     
    leeshor likes this.
  4. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    That makes more sense. ;)
     
  5. Eplak

    Eplak Member

    Joined:
    Feb 1, 2016
    Messages:
    49
    Likes Received:
    7
    Trophy Points:
    8
    Location:
    Norway
    My Device:
    SPro4
    hughlle is right. A little vague from me, and my native language is not English.

    The point here is that this problem did not occur on my previous SP4. Therefore I wonder why this is happening now.
    The phone is a Lumia 930, and has the ability to slow charge.
     
  6. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,698
    Likes Received:
    422
    Trophy Points:
    83
    A slim possibility, but try a different usb cable (i know it worked previously, but you never know) My phone is constantly disconnecting due to usb cables. Only one i have actually creates a stable connection.
     
  7. Eplak

    Eplak Member

    Joined:
    Feb 1, 2016
    Messages:
    49
    Likes Received:
    7
    Trophy Points:
    8
    Location:
    Norway
    My Device:
    SPro4
    I will definitely try that when i have access to one, but the cable seems fine when connected to a wall adapter.
     
  8. Eplak

    Eplak Member

    Joined:
    Feb 1, 2016
    Messages:
    49
    Likes Received:
    7
    Trophy Points:
    8
    Location:
    Norway
    My Device:
    SPro4
    My LaCie Rugged mini 1,5 TB hardrive is working just perfect, so i guess my phone's slow charge is misbehaving a little bit. Thought you might want to know.
     
    leeshor likes this.
  9. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Good to know. Thanks for the update.
     
  10. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,698
    Likes Received:
    422
    Trophy Points:
    83
    I just thought I'd clarify what I meant by slow charge. I dont mean slow in that it's not a fast charging protocol like on newer phones, but slow charge in that it is below even a normal charge. On my phone I get a warning message saying that it is slow charging with a big triangle and exclamation mark. If I were to watch YouTube while in this slow charge state, the battery would discharge.
     
  11. Eplak

    Eplak Member

    Joined:
    Feb 1, 2016
    Messages:
    49
    Likes Received:
    7
    Trophy Points:
    8
    Location:
    Norway
    My Device:
    SPro4
    Yes, i understood what you meant. I have gotten that message on my Lumia 930 before, so i am familiar with the term.
     
    hughlle likes this.
  12. Eplak

    Eplak Member

    Joined:
    Feb 1, 2016
    Messages:
    49
    Likes Received:
    7
    Trophy Points:
    8
    Location:
    Norway
    My Device:
    SPro4
    UPDATE: The new 2/17/2016 Firmware update seems to have fixed the issue.
     

Share This Page

Search tags for this page

keep usb port from disconnecting

,

windows usb not working connects disconnects