What's new

Awake from Sleep - Strange Power Button behaviour

evil-twin

New Member
Hi guys,

Since the past couple days I have a strange behaviour when trying to wake my Surface RT from sleep. I push the Power-Button on top and nothing happens. When I than push the button a second time it finally wakes up immediatly. I can without difficulty bring the device to sleep by pushing the Power-Button and immediatly bring it back to life by pushing it again. But when my Surface was in Sleep mode for about 2 minutes or more I always need to push this button twice before it wakes up. I even completly resetted my Surface completely (including formatting all data) but this strange behaviour still keeps annoying me.

Is there a setting for this behavoiur or something or does it look mor like a fault. Any experiences, ideas or solutions for that?

Thanks for all the help in advance.
 

john.calixte

New Member
My Surface RT has also had wake-up problems since the March 12 updates. Although my symptoms are slightly different:
- I have to hit the Start button many times to wake up.
- but unlike you, my power button seems to work OK for wake up.
I'm hoping the next update will fix this.
 

thix84

New Member
My experience with power button is bit different. When I shutdown my RT, there are times that it doesn't turn on. After couple of tries, it works.This is occurs,randomly. Updates and refreshing my RT doesn’t help. Didn’t try to format..
 
OP
E

evil-twin

New Member
Ok, you mean these problems may have come with one of the last Firmware-updates which should improve overall stability. This would make sense. It happens roughly since the last update and doesn't look like a hardware fault. Hope MS knows about this and is working on a fix...

Should have checked this behaviour after resetting my Surface to factory settings but I immediatly reinstalled all updates (including Firmware) afterwards.

Will test this behaviour with the Start/Home-button (actually never woken up my device with this one) and report later.

UPDATE:

I checked the waking of the device with the Home-Button and it need up to 7 tries to get the Surface alive. This is getting a bit annoying now...
 
Last edited:

J515OP

Super Moderator
I have been noticing the same since the firmware update. Not the end of the world but it can take up to 30 seconds or so to get it to wake up (half a dozen to a dozen presses). I'm sure the next up date or two will have a fix.
 

john.calixte

New Member
So the March 12 firmware updates seem to have messed up the Start button wake-up function. Until MS fixes this, a good workaround is to hit the Power button instead. At least this works for me.
 

ArnoldC

New Member
I have the Touch Cover always connected and it always wakes up my RT by pressing CTRL. It still does that after the update.

Will have to try the power button when I get to the office.
Sent from my Windows Phone 8S by HTC using Board Express

edit:

I tried it just now, no issues and works like before, .i.e. single short press and it is awake.
 
Last edited:

john.calixte

New Member
Suddenly Monday morning (March 18) my Start button wake-up functionality seems to have returned. One tap wakes up the Surface. I fully recharged the battery last night - coincidence? Hmmm.
 

Omni

Active Member
I've noticed it takes a couple of attempts to wake the surface with the power button. Not tried the start button didn't relies it did wake it up. Hope it will get fixed it is a little annoying.
 

Inadorel

Member
I thought it was just me - but I have noticed the same thing - and I am pretty sure it happened with the last round of updates. Pressing the home key sometimes takes four or five presses before it wakes the device up - pressing the power key invariably works though.
 

J515OP

Super Moderator
Yes, I have to press the power button twice at most. Windows key can be half a dozen presses. I'm sure a future update will resolve the he issue.
 
Search tags for this page
have to hit power button twice microsoft surface
power button not working surface rt

surface power button

surface pro 2 power button
surface pro 2 wakes after sleep button pressed
surface rt power button
surface rt power button issues
surface rt power button problem
surface rt wont wake from sleep
windows surface won't wake-up until multiple pushes of the start button

Members online

No members online now.
Top