What's new

Dear MS, can you PLEASE get your act together on these updates?

mitchellvii

Well-Known Member
A little spleen venting here.

Yesterday all of my Modern UI Apps decided they would no longer launch. No explanation, they just stopped. I searched Google extensively and tried every trick, nothing could save them. So, I decided to take hours out of my busy day and do a full wipe and refresh.

Now I am trying to install updates and as soon as they get to 14 or 15% complete, they FAIL every single time. This is a brand new install with NO other software installed other than Modern UI Apps and the updates STILL fail? Dear MS, do you even test these before pushing them out the door? For a company the size of MS this kind of sloppiness is completely unacceptable. Can I spend even more of my time tracking down the offending update and hide it. Yes, but I shouldn't have to do quality control for MS.

Once again, I've tried all the tricks, unplugged everything, taken out the SDCard, and still the updates fail. I ran sfc /scannow and no errors. I am just tired.
 

tonyz3

New Member
did you try installing them one at a time- that usually works for me when this happens. BUT yes i agree the update issues are frustrating.
 
OP
mitchellvii

mitchellvii

Well-Known Member
did you try installing them one at a time- that usually works for me when this happens. BUT yes i agree the update issues are frustrating.
18 updates one at a time. Sounds fun but I already met my quota of sticking needles in my eyes for the day.
 

souldier

Active Member
That's unfortunate. Every update has installed flawlessly on my pro since the start. Hope you are able to figure it out.
 

DOS

Active Member
My gut reaction to this thread was … karma?

But then I thought, No! I’m on Mitch’s side now. Come on Microsoft, get your act together!

And Mitch, how can you be so calm? I would have expected a thorough tongue lashing for Microsoft regarding such an issue! Normally, you slap them around worse than this when you’re complimenting them!

Don’t give up, don’t give in to the Dark Side! Give ‘em hell!

On a lighter note, could this be a Wi-Fi issue?
 

tonyz3

New Member
it is inconvenient but if you have this problem which i did twice it was fixed with updating one at a time.
 

Members online

Top