What's new

"display driver stopped responding and has recovered"


New Member
Every once and a while I get the above message as Adobe Photoshop CC (2014) opens on my Surface Pro 3 (i7 256GB). If I continue on to Photoshop some parts of the advanced graphics system are shut down (I'll try to get some screenshots next time it happens) but Photoshop still functions. I can usually exit PhotoShop... restart the Surface Pro... and operate with no problems.

I've tried updating the graphics driver... Windows reports it is using the latest version.

Any thoughts or ideas?


Super Moderator
Staff member
File a bug report with both MS and Adobe. There should be a dump with this failure which should accompany the bug submission.


New Member
I might found a solution.....

I had the same problem on my s2.
Every time I waked up the surface, the Nvidia Tegra 4 driver was apparently crashed (huh? when?) and 'succesfully' re-activated. For about 16 times.
That meant I had to click a few minutes trough the error popups, before I could use my s2.

I've been reading, it may had to do with a windows feature called 'TDR' wich monitors the display driver (if it's on or not - or something)
When the device is a sleep, the driver is off, which triggers the darn TDR thingy on wakeup.

Here is the thing: I've found online two edits on that process (in regedit).
1 - we can set a delay on the trigger. TDR waits with panicking, gives the driver a chance to yawn and reset. Doesn't work on sleep, or we need to set the delay for a day or so... lol
2 - stop the TDR monitoring. Period. That seems to work. XP had no TDR to begin with and that worked just fine.
So I stopped the TDR on my surface 2, and now I'll wait if it worked.

For the daring people, here how it is done:

  1. Exit all Windows based programs.

  2. Click Start, type regedit in the Search box, and then double-click regedit.exe from the results above. (If you are prompted for an administrator password or confirmation, type the password or provide confirmation)

  3. Browse to and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002 (sometimes called ControlSet001) \Control\GraphicsDrivers

  4. On the Edit menu, click New, and then select the following registry value from the drop-down menu specific to your version of Windows (32 bit, or 64 bit):
    Select DWORD (32-bit) value if you have an 32 bit version of Windows
    - or select DWORD (64-bit) if you have an 64 bit version (duh!)

  5. Type TdrLevel as the Name and click Enter.
  6. Double-click TdrLevel and enter the data value as 0 (it is set to that natively, but double check)

  7. Restart.

That completely turns off Tdr checker, so now windows 7/vista/8 now works more like windows XP

If you still want the checker on, but with the delay, just simply make an TdrDelay, instead of TdrLevel, and set it's value to 8
Only one of those can be in there, otherwise they will fight each other and that's never a good thing!

Mind you - I'm still testing if this works!!!
Last edited:


New Member

TdrLevel (deactivating the checker) has a negative behavior on my device: Display won't wake up. Now I have to hard-button forcing my s2 to shutdown and then boot it again (wich takes a minute all toghether). :eek:

TdrLevel is not a good idea, for me. Now I'm trying the TdrDelay witch 8 sec.
Fingers crossed!


Active Member
I had the same thing on my SP2, guessing something between the intel gfx and PS just don't work.

I found rebooting often fixed it though :)

Members online

No members online now.