What's new

My marvell network driver version is still 14.69.24039.134

OP
M

manfromwest

New Member
Finally, I fixed all my problem.

Spike_Spiegel thank you for advice. but your first advice not work for me.
So I tried next one, the change the recovery file.

make usb boot media and update the driver files to OCT 2013 update drivers.

Now, my sp2 seems works perfect.

I followed the instruction.
and every driver marks are gone.

thank you very much!!
 
Last edited:

macmee

Active Member
First off, how in the hell is this even a problem? Microsoft made this machine and wrote Windows. Are they not capable of pushing out an update that gets us all on the latest version of this driver? :confused: Their indifference or inability to fix the problems with our $1000-2000 device continues to confuse me on a daily basis. They have had YEARS to perfect Windows updates, what the hell is wrong with these people?

Do real engineers work on the Surface, or do interns with arts degrees oversee the product? Based on its poor quality I'm beginning to think the distinction would be irrelevant. This device is so broken.

I'm 14.69.24044.150 from 2013-09-19. No update after the latest firmware install, no update when I manually attempt to update through device manager.

I'm sure my new Surface will have the latest drivers installed, but it's been 9 days and hasn't shipped yet. And come to think of it, it wouldn't surprise me if Microsoft just sent me a refurbished unit or a new unit with outdated software. I don't think Microsoft really cares about its users, just about selling these things.

I installed the january update and my Wifi Driver didn´t update. It stays at 14.69.24044.150.
Microsoft doesn't have a clue what they're doing. I'm not sure if they ever did. The moment Apple releases a touchscreen device with OS X I'm jumping ship. The only Microsoft product I haven't had issues with is Office.......
 
Last edited:
Maybe the January update was only for the uefi and the guys with the .160 wifi Driver had installed the December update which I didn't installed.
 

macmee

Active Member
Maybe the January update was only for the uefi and the guys with the .160 wifi Driver had installed the December update which I didn't installed.
I installed the December update. It gave me many software related issues, but no new wifi driver.
 

eelpout

Member
I wonder if there could two variations of the Marvell Avastar 350N in the production runs and that might account for the driver differences. iFixIt found a 88W8797 inside their teardown.

Microsoft Surface Pro Teardown - iFixit

(I'm still on 14.69.24044.150 as well, I have a 4300u processor)
 
Last edited:

bigdata

New Member
If you have an SP2, your driver should be 14.69.24044.150 according to the driver pack yesterday released by MS. The .160 driver works for the Pro, and just for the hell of it I downloaded it and tried it on my Pro 2, but it didn't work, so I would recommend the .150 version until there is an official update.

I also had the problem where for some reason after the December firmware update I got downgraded from the .150 driver back to the .134 driver, which caused problems with Miracast. I tried to manually install the .150 driver, but it just wouldn't work (same as OP). I really didn't want to do a PC Refresh because everything else is working just great, so I asked my brother who is an IT guy if there is another workaround without doing a refresh. He suggested I manually swap out the driver file using file manager instead of device manager. Per his suggestion, I downloaded the January driver pack from the MS web site, and in the Marvell folder, there is a file called mwlu97w8x64.sys. This is the .150 driver. Then, I went into c:\window\system32\drivers and moved the mwlu97w8x64.sys file (which is the v. .134) to the desktop (just in case), and moved the newer mwlu97w8x64.sys file from the driver pack that I had downloaded from the MS site into the c:\window\system32\drivers folder. Then I rebooted my computer, and my Miracast was working perfectly again.

If I go into device manager, it still shows the .134 driver, but the actual driver file in the system drivers folder is .150. So, if you can live with that discrepancy it's a much easier fix. I'm not sure if this will cause an issue if/when there are future Marvell driver updates, but for now it's a quick fix that I can live with.
 

eelpout

Member
that's interesting because I've gone back and forth from the .134 driver (using Marvell's installer) to .150 several times. Windows Update always brings me back to .150 if I let it.
 

bigdata

New Member
Where did you find Marvell's installer? Windows Update for some reason won't update me past .134. Apparently the OP is having the same problem. .150 is much better for Miracast
 

Dayton

Member
I installed the December update. It gave me many software related issues, but no new wifi driver.
I think 160 was pulled, my driver reverted to 150 through Windows Update. I'm not worried about it and don't understand why anyone would unless they are having WiFi issues. If so you can get 136 which while not the latest is a stable release.
 
I have the latest driver but the WiFi seems to interfere with Bluetooth whenever I have both enabled. Internet speeds drop substantially when Bluetooth is on and connected. Wish they would fix this.
 
Search tags for this page

14.69.24049.160

download marvel driver 14.69.24049.160
marvel 14.69.24049.160
marvel 350n driver surface pro 2
marvell avastar 350n wireless driver 14.69.24049.160 miracast compatible
marvell driver for surface pro 2

surface pro 2 marvell driver

surface pro 2 marvell wireless the device is not configured properly
surface pro 2 network driver not installed

version 14.69.24049.160

Staff online

Members online

Top