What's new

Power Button Not Following Power Settings

CGriesinger

New Member
Normally, when I hit the power/lock button, my surface would "sleep." My surface would also sleep when I "close the lid." Now, all of the a sudden, every time I hit the power button it brings up the shutdown screen. I went to the power settings and confirmed that regardless of whether the surface is plugged in or using battery, hitting the power button should make the surface sleep.

Is this happening to anyone else?
 

hughlle

Super Moderator
Staff member
Welcome to the forum.

I've not experienced this with my sp4 at all. Beyond something software related (have you tried booting with a usb version of ubuntu etc to see if it is software or hardware) it might be possible that dirt or something has gotten underneath, and is effectively resulting in a long press (like when a keyboard gets a little dirty and the key doesn't rapidly return when pressed)
 
OP
C

CGriesinger

New Member
I had not tried that... but I found a solution elsewhere. A hard restart (holding the power button for 30 seconds) did the trick. Not sure why. Not sure how it happened in the first place, but everything is working now!
 

MikemanSP4

Super Moderator
Staff member
Try this - Reset the Power Settings to Default - Then test your button / lid. Then go back and adjust each one under Change Advanced Power Settings. I have found that sometimes, Windows, especially after an update - will need a little coaxing to work correctly, and restoring the Default Power Settings will sometimes overwrite any corruption that may have occured.

Have you turned off the "Hibernation" function if not in use? If not, go to a Admin Command Prompt and enter "powercfg -h off " (without quotation marks of course;)). Also - check your Device Manager to ensure there are no issues usually indicated by a Yellow Triangle with an ! in it. Even though I don't think you would have one, it never hurts to check.

Hope this helps a little.

Mike
 

Members online

No members online now.
Top