What's new

RDP into your Surface Pro

dlacaba

Member
Hey all, Is anyone else having problems with this? I was able to do this before, but just can't seem to get it to work anymore. Not sure what I changed.

I can log into the machine just fine, but it disconnects once I can see the desktop. When I look at the Surface Pro, it appears that the Network adapter sleeps or something, because it displays as limited connection(Wireless bars with * above it) once I RDP to it. When I log into the surface pro, it says that my user id is already logged in from the client machine.

I've unchecked the power management option for the Marvel AVASTAR network adapter to "Allow the computer to turn off this device to save power" and still no luck. Anyone else here have issues with theirs and if they were able to fix it?
 

J515OP

Super Moderator
Chances are that it isn't the Marvell chip that is causing the sleep issue. You should try setting the entire power profile to never sleep instead of focusing on the wifi chip.
 
OP
D

dlacaba

Member
Yup tried that too, I set my power options to High Performance.

Also tried changing the balanced one so that the wireless adapter setting's power saving mode is maximum performance for on battery/plugged in.
 

machistmo

Active Member
I noticed problems just trying to C$ the unit. I disabled firewalls and enabled all the relevant remote settings. So far I have only wanted to RDP to other machines from my surface, which works perfectly. I will try it in reverse at work on Monday. I don't have to carry my laptop with me anymore since I have the Surface Pro to use now.
 
Search tags for this page
mstsc surface
mstsc surface pro

rdp on surface pro

rdp to surface pro

rdp to surface pro 3
surface mstsc resolution
surface pro mstsc

surface pro rdp

surface pro rdp resolution
surface pro suppoer rdp?

Members online

No members online now.
Top