What's new

Solved screen brightness keeps changing, disabled auto brightness

lightman

New Member
Hi this is my first post. I got my sp4 pro around the middle of December and it has been working really well for me overall. The one thing that continues to bug me is the screen will change its brightness even though I have disabled the auto brightness in the settings. where it shows up the most is if I run acdsee with a dark background interface after a few seconds the screen will dim, if I then open up a file explorer folder over top of the interface the screen will brighten back up until I bring acdsee back to the front then it dims again.
Is there anyway to disable the constant dimming of the screen with dark backgrounds that are full screen.
 

leeshor

Well-Known Member
Welcome to the forum

Your explanation makes it sound as if the app is causing the issue. Does it do that with any other app. Autobright should work based on the ambient light not what's happening on your Surface.
 
OP
L

lightman

New Member
Thanks for the reply.
All my other computers don't do this with acdsee or any other program.
It will do it with you tube as well if the video I'm playing has a dark background like this one
If I play it full screen the display will dim after a few seconds, if I open up a file folder with the windows + e key over top the screen brightness will come back up. After I close the file folder window the screen will dim again after a few seconds.
It's not a dramatic dimming but it is noticeable. it almost looks like it is dropping the contrast and it does it gradually almost so you wont notice. When you open up the the file manger window you can see it gradually ramp back up.
 

Eplak

Member
I have exactly the same issue. It happens especially in the Groove Music app, with dark theme. I have done some research on it, and it is some sort of automatic power saving. If you connect the charger, you will not experience the same problem. I am not sure on how to fix it, but maybe you have to go into some advanced settings in the Control Panel.
 

alexd88

Member
same problem here with viedo playing in vlc when i am on battery and the power is less than 20%. if i dissable ecopower & i make the brightenes more tha 25%, would not do it anymore. the problem seem it has appeared after last update, i have the microsoft intel driver.
 

leeshor

Well-Known Member
It must be yet another issue related to video drivers. But unlikely related to autobright settings even if the symptoms appear the same. If that were the case you would have a bad sensor.
 
OP
L

lightman

New Member
Well it looks like it's a problem on the spro3 as well.
Here is a link to the discussion
Auto brightness disabled, yet still there. How to get rid of it?
Post #17 quote
"On the Surface Pro 2 and 3, Intel dynamic contrast ratio is enabled by default on battery. Intel like to calls it "Power Saving", but using software that can tell me how much the battery is being used (discharged rate) and I have not notice any power saving from this feature, and acts exactly like dynamic contrast ratio. You can normally disable this in the Intel control panel, but Microsoft is not including it"

2 generations ago they had the problem and it looks like Microsoft seems to think its a good feature and not a bug.
 

leeshor

Well-Known Member
Hmm. I don't have that problem and I'm pretty much stock. I manually set my brightness to 35% and never have seen it vary.
 

sharpuser

Administrator
Staff member
I believe this is a video driver issue. I can make this happen on my Surface Book while streaming video from Slingbox.

The Slingbox people indeed blame the problem on software / video drivers.

Good news is that your Surface computer (hardware) is fine.
 
OP
L

lightman

New Member
I just confirmed that it is a driver issue. I downloaded and installed the latest intel video drivers #20.19.15.4352 from 2015-12-15.
after the install and a reboot I have access to the intel graphics driver panel in the tool bar or through the display driver advanced options. Here is a pic of the display panel with the option circled in red set to disabled.
After setting that to disabled the dimming no longer occurs.


upload_2016-2-3_12-50-29.jpeg
 

sharpuser

Administrator
Staff member
Thanks - I marked it solved, but actually, will be solved soon, as a better driver is sourced from Microsoft. In any case, this is a workaround for those whom need relief.
 

Members online

Top