What's new

Sleep issue - turned off instead of sleep

sagatiba

New Member
Hi guys,

Yesterday I had a weird sleep issue. I saw some people are having issues with the auto sleep, that's not my case.
What happened is that yesterday I put my SP2 to sleep by pressing the sleep button and today morning it was turned off, not sleeping.

It was plugged in, the sleep button is set to sleep in both battery and plugged in modes and it is not set to auto turn off. And windows updates do not install without authorization.

I tried today to put it to sleep and it worked, but I left it sleeping for just 30 seconds, I think the problem happens and it sleeps for a very long time.

Anyone knows if the SP2 has any configuration to auto turn off after some hours of sleep...?

All updates installed
Feb FW installed
Battery 100% charged
 
OP
S

sagatiba

New Member
Did you check the hibernate settings? By default I think MS sets the machine to hiberate after 3 hours when plugged in.

I did not check it but i think that's not the case, because when I powered it on my applications that were opened were not anymore! Was a clean start up.
 

grumpy

Active Member
It sounds like it might have failed to resume from hibernation. This was an issue prior to the October update, but I have still had it happen a couple of times. Look at the "System Logs" in the "Event Viewer" to see what errors are being reported. You might want to manually hibernate it a couple of times to make sure that there is not a persistent hibernation issue.
 
OP
S

sagatiba

New Member
It sounds like it might have failed to resume from hibernation. This was an issue prior to the October update, but I have still had it happen a couple of times. Look at the "System Logs" in the "Event Viewer" to see what errors are being reported. You might want to manually hibernate it a couple of times to make sure that there is not a persistent hibernation issue.

Is hibernation enabled by default? because I have never enabled it! As soon as I get home I check the log.

Thanks for the help!
 
I disabled hibernation because it crashed too often. The event viewer will have a kernel error message if it crashed. I haven't tried re-enabling hibernation since the recent firmware update.
 

grumpy

Active Member
I disabled hibernation because it crashed too often. The event viewer will have a kernel error message if it crashed. I haven't tried re-enabling hibernation since the recent firmware update.

Hibernation has been a bit of a problem for the SP2. Before the Oct update it seemed unable to successfully wake from hibernation. The Oct update fixed that issue, but then the display driver would frequently crash during hibernation. The Dec update caused my SP2 to, instead of hibernating, wake up and run the system process at 30% all night. After the Jan update (and the 3368 display drivers) hibernation seems pretty stable. Although, it has still failed to wake from hibernation once, and I can't hibernate with the mSD card inserted unless I want it to wake up with a "runaway" system process.

I never had any of these issues with the SP1...
 

Members online

No members online now.
Top