What's new

Surface Pro 4 - type cover not working

CVFZ

New Member
Hi guys,
I have a Surface Pro 4 and it's type Cover doesnt work. I tested with 2 Covers, none works.
Both Cover work on a SP5.
The Cover doesnt work in Windows, and also not in bios. I have latest Windows 10 (22H2) on it.
What i already tried:
Reset Windows
Volume Up + Power Button reset
Install Cover backwards
Delete drivers and install (also no surface Cover shown under Keyboards, only on hid keyboard. Surface type Cover Integration also not under hid Devices)
Firmware downgrade (installed the 17763 and earlier)
Clean contacts with alcohol

Nothing of this helped.

Anyone another idea for that?
 

demokedes

New Member
Hi guys,
I have a Surface Pro 4 and it's type Cover doesnt work. I tested with 2 Covers, none works.
Both Cover work on a SP5.
The Cover doesnt work in Windows, and also not in bios. I have latest Windows 10 (22H2) on it.
What i already tried:
Reset Windows
Volume Up + Power Button reset
Install Cover backwards
Delete drivers and install (also no surface Cover shown under Keyboards, only on hid keyboard. Surface type Cover Integration also not under hid Devices)
Firmware downgrade (installed the 17763 and earlier)
Clean contacts with alcohol

Nothing of this helped.

Anyone another idea for that?
I have very similar experience. My Surface Pro 4 was working fine for several years. Few weeks ago, keyboard cover stopped working. While troubleshooting, I realized bluetooth is not working. Surface is behaving, like there is no bluetooth. In UEFI, bluetooth is enabled, but in windows no bluetooth is recognized.
Even after I reinstalled Surface Pro 4, again no bluetooth and keyboard cover is not working, althouth the same keyboard is working on other Surface. I cleaned ports, but it is not helping.
Any idea?
 
OP
CVFZ

CVFZ

New Member
Did you also Try to downgrade Firmware? Bluetooth works on mine, but no type Cover.
I would like to downgrade the SAM and / or EC Firmware, but this doesnt work...
 

Jeff Constance

New Member
I've had this problem for years now. None of the suggested solutions from Microsoft work. I also bought a new Alcantara keyboard for my SP4...didn't work. It's been suggested that the problem occurred as a result of an update. As it stands I've got a very expensive keyboard that won't work and probably never will. Microsoft support has been awful and they continually suggest the usual "remedies".... none of which work. I will never purchase from Microsoft again due to their discgraceful customer service. If anyone does come up with a working solution I would be most grateful.
 
Top